summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-12 07:59:08 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-12 07:59:08 +0000
commitff041a396bfb87363f2f76a360c977cdfd7e2b19 (patch)
treec27096fa95df7400686e65ff83f28365990a0814 /sci-calculators/galculator/galculator-1.3.4.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-ff041a396bfb87363f2f76a360c977cdfd7e2b19.tar.gz
historical-ff041a396bfb87363f2f76a360c977cdfd7e2b19.tar.bz2
historical-ff041a396bfb87363f2f76a360c977cdfd7e2b19.zip
Version bump per bug #268462, switch to eapi-2 in order to replace src_unpack() by src_prepare(), clean-up the testsuite fix, add a || die to dodoc
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'sci-calculators/galculator/galculator-1.3.4.ebuild')
-rw-r--r--sci-calculators/galculator/galculator-1.3.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-calculators/galculator/galculator-1.3.4.ebuild b/sci-calculators/galculator/galculator-1.3.4.ebuild
new file mode 100644
index 000000000000..024b69d5351e
--- /dev/null
+++ b/sci-calculators/galculator/galculator-1.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/galculator/galculator-1.3.4.ebuild,v 1.1 2009/09/12 07:59:08 mrpouet Exp $
+
+EAPI="2"
+
+DESCRIPTION="GTK+ based algebraic and RPN calculator."
+HOMEPAGE="http://galculator.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ gnome? ( gnome-base/gnome-desktop )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gnome || sed -i -e 's:gnome-calc2.png:calc:' "${S}"/galculator.desktop.in
+ # Fix tests
+ echo ui/*.glade | tr -t ' ' '\n' >> po/POTFILES.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}