summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-17 23:58:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-17 23:58:16 +0000
commit2552a1c1f8282dc6c2c4f392cb4f0c7ea67be45c (patch)
tree66c976684ed5607e75d554649d291cddfaf6347a /sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
parentFix patch with absolute paths. (diff)
downloadhistorical-2552a1c1f8282dc6c2c4f392cb4f0c7ea67be45c.tar.gz
historical-2552a1c1f8282dc6c2c4f392cb4f0c7ea67be45c.tar.bz2
historical-2552a1c1f8282dc6c2c4f392cb4f0c7ea67be45c.zip
Import to the main tree from the science overlay and version bump with translation fixes
Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild')
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
new file mode 100644
index 000000000000..43ec49f57bc9
--- /dev/null
+++ b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild,v 1.1 2008/11/17 23:58:15 bicatali Exp $
+
+EAPI=1
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A fast and usable calculator for power users"
+HOMEPAGE="http://speedcrunch.org/"
+SRC_URI="http://speedcrunch.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="|| ( >=x11-libs/qt-4.2:4 x11-libs/qt-gui:4 )"
+
+LANGS="ca cs de en es es_AR eu fi fr he id it nb nl no pl
+ pt pt_BR ro ru sv tr zh_CN"
+for lang in ${LANGS}; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack( ) {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-iconname.patch
+ # regenerate translations
+ lrelease speedcrunch.pro || die
+ for lang in ${LANGS}; do
+ if ! use linguas_${lang}; then
+ sed -i -e "s:i18n/${lang}\.qm::" Translations.cmake || die
+ sed -i -e "s:books/${lang}::" CMakeLists.txt || die
+ fi
+ done
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd ..
+ dodoc ChangeLog ChangeLog.floatnum HACKING.txt LISEZMOI README TRANSLATORS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf || die
+ fi
+}