summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-21 15:21:35 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-21 15:21:35 +0000
commit5e90c0559b4b195360d11f95403e8f2b9b420d09 (patch)
treebb413298a4e6ccb2615db724a568b88c9f4e1d7b /sci-chemistry/aqua/aqua-3.2-r2.ebuild
parentsilc-plugin replaced by silc-client. (diff)
downloadhistorical-5e90c0559b4b195360d11f95403e8f2b9b420d09.tar.gz
historical-5e90c0559b4b195360d11f95403e8f2b9b420d09.tar.bz2
historical-5e90c0559b4b195360d11f95403e8f2b9b420d09.zip
Fix for parallel make, #359801
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/aqua/aqua-3.2-r2.ebuild')
-rw-r--r--sci-chemistry/aqua/aqua-3.2-r2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sci-chemistry/aqua/aqua-3.2-r2.ebuild b/sci-chemistry/aqua/aqua-3.2-r2.ebuild
index 81005f321137..d5742aba277f 100644
--- a/sci-chemistry/aqua/aqua-3.2-r2.ebuild
+++ b/sci-chemistry/aqua/aqua-3.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/aqua/aqua-3.2-r2.ebuild,v 1.1 2010/11/16 17:12:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/aqua/aqua-3.2-r2.ebuild,v 1.2 2011/03/21 15:21:35 jlec Exp $
EAPI="3"
@@ -50,6 +50,14 @@ src_compile() {
CFLAGS="${CFLAGS} -I../sub/lib" \
FFLAGS="${FFLAGS}" \
LDFLAGS="${LDFLAGS}" \
+ exth || die
+ emake \
+ MYROOT="${WORKDIR}" \
+ CC="$(tc-getCC)" \
+ FC="$(tc-getFC)" \
+ CFLAGS="${CFLAGS} -I../sub/lib" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
|| die
popd
}