summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-27 19:37:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-27 19:37:57 +0000
commit14e1fbbf98852091bca9837e14fe5b1c54000f40 (patch)
treeed02a51188e59e204be7dcb15193acd4e107bd03 /sci-electronics/gnucap/gnucap-0.34.ebuild
parentMoving to sci-electronics/gnucap (diff)
downloadhistorical-14e1fbbf98852091bca9837e14fe5b1c54000f40.tar.gz
historical-14e1fbbf98852091bca9837e14fe5b1c54000f40.tar.bz2
historical-14e1fbbf98852091bca9837e14fe5b1c54000f40.zip
Moved from app-sci/gnucap to sci-electronics/gnucap.
Diffstat (limited to 'sci-electronics/gnucap/gnucap-0.34.ebuild')
-rw-r--r--sci-electronics/gnucap/gnucap-0.34.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-electronics/gnucap/gnucap-0.34.ebuild b/sci-electronics/gnucap/gnucap-0.34.ebuild
new file mode 100644
index 000000000000..861921bb9ede
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-0.34.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.34.ebuild,v 1.1 2004/12/27 19:37:57 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://geda.seul.org/dist/gnucap-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gnucap"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc-3.4.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ insinto /usr/bin
+ doins src/O/gnucap
+ doins ibis/O/gnucap-ibis
+
+ fperms 755 /usr/bin/gnucap
+ fperms 755 /usr/bin/gnucap-ibis
+
+ cd doc
+ dodoc COPYING acs-tutorial whatisit history
+ doman gnucap.1 gnucap-ibis.1
+}