summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-01-29 06:27:42 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-01-29 06:27:42 +0000
commite69cff7468ef119c80d2d23325d4ad7be4b0def7 (patch)
treece63f4ec3d05f3d75dfbecf918e72a2c4db6ae69 /sci-libs/buddy/buddy-2.4.ebuild
parentclean old ebuilds/patches (diff)
downloadhistorical-e69cff7468ef119c80d2d23325d4ad7be4b0def7.tar.gz
historical-e69cff7468ef119c80d2d23325d4ad7be4b0def7.tar.bz2
historical-e69cff7468ef119c80d2d23325d4ad7be4b0def7.zip
Bump to most recent version. This fixes bug #119582.
Package-Manager: portage-2.1_pre4
Diffstat (limited to 'sci-libs/buddy/buddy-2.4.ebuild')
-rw-r--r--sci-libs/buddy/buddy-2.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/buddy/buddy-2.4.ebuild b/sci-libs/buddy/buddy-2.4.ebuild
new file mode 100644
index 000000000000..3d5a559c2f9d
--- /dev/null
+++ b/sci-libs/buddy/buddy-2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.4.ebuild,v 1.1 2006/01/29 06:27:42 markusle Exp $
+
+DESCRIPTION="BuDDY - A Binary Decision Diagram Package"
+HOMEPAGE="http://sourceforge.net/projects/buddy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE=""
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf || die "econf failed"
+}
+
+src_install() {
+ emake || die "emake failed"
+ make install DESTDIR=${D} || die "make install failed"
+
+ dodoc ChangeLog NEWS AUTHORS README doc/*.txt || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${P}/ps
+ doins doc/*.ps || die "failed to install postscripts files"
+
+ insinto /usr/share/${PN}/examples
+ cd examples
+ for example in *; do
+ tar -czf ${example}.tar.gz ${example}
+ doins ${example}.tar.gz
+ done
+}