summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-08-10 14:00:53 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-08-10 14:00:53 +0000
commit7e2fac2d414c195abb65265b31fea4faed5b575c (patch)
tree5aa5bf57f7969a0d1de8e7d898bc3cac269b2bc5 /sci-libs/fftw
parent~amd64 (diff)
downloadhistorical-7e2fac2d414c195abb65265b31fea4faed5b575c.tar.gz
historical-7e2fac2d414c195abb65265b31fea4faed5b575c.tar.bz2
historical-7e2fac2d414c195abb65265b31fea4faed5b575c.zip
Fixing insecure temp file generation of fftw-wisdom-to-conf, see bug #101771
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/Manifest11
-rw-r--r--sci-libs/fftw/fftw-3.0.1-r2.ebuild99
-rw-r--r--sci-libs/fftw/files/3-tmpfile.patch16
-rw-r--r--sci-libs/fftw/files/digest-fftw-3.0.1-r21
5 files changed, 130 insertions, 5 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index c9960549e5b4..271598f0dff6 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.15 2005/07/17 21:55:00 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.16 2005/08/10 14:00:53 phosphan Exp $
+
+*fftw-3.0.1-r2 (10 Aug 2005)
+
+ 10 Aug 2005; Patrick Kursawe <phosphan@gentoo.org> +files/3-tmpfile.patch,
+ +fftw-3.0.1-r2.ebuild:
+ Fixing insecure temp file generation of fftw-wisdom-to-conf, see bug #101771
17 Jul 2005; Hardave Riar <hardave@gentoo.org> fftw-3.0.1-r1.ebuild:
Keyworded ~mips
diff --git a/sci-libs/fftw/Manifest b/sci-libs/fftw/Manifest
index 4c36f6d30868..5622f2ecefd8 100644
--- a/sci-libs/fftw/Manifest
+++ b/sci-libs/fftw/Manifest
@@ -1,9 +1,12 @@
-MD5 d4f4a84c465357574f81dbcf4bb0fd92 ChangeLog 5863
-MD5 b0b309c7dfe2c8566424e91792350f95 fftw-2.1.5-r1.ebuild 4141
-MD5 4a8f8342448809b69143f66d02e7f2d2 fftw-3.0.1-r1.ebuild 2759
MD5 7b8ca418c402f3091eeb2cefd710e739 fftw-3.0.1.ebuild 2363
+MD5 f0f860b590338a58214e6200ffb101e8 fftw-3.0.1-r2.ebuild 2733
+MD5 4a8f8342448809b69143f66d02e7f2d2 fftw-3.0.1-r1.ebuild 2759
+MD5 b0b309c7dfe2c8566424e91792350f95 fftw-2.1.5-r1.ebuild 4141
+MD5 cd36716647a715e19d8961bff1064276 ChangeLog 6076
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 236dda9695005c9f306fb2c55f020686 files/digest-fftw-2.1.5-r1 63
MD5 cd32698a34d886267d48a8ccb99747b1 files/digest-fftw-3.0.1 63
MD5 cd32698a34d886267d48a8ccb99747b1 files/digest-fftw-3.0.1-r1 63
+MD5 cd32698a34d886267d48a8ccb99747b1 files/digest-fftw-3.0.1-r2 63
MD5 7718e5a1330e574b38daecb472bffa17 files/fftw-ppc-macos.patch 1356
+MD5 1395bb17e5d04e7050eab24d5b7b25d1 files/3-tmpfile.patch 538
+MD5 236dda9695005c9f306fb2c55f020686 files/digest-fftw-2.1.5-r1 63
diff --git a/sci-libs/fftw/fftw-3.0.1-r2.ebuild b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..4835d17646cb
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r2.ebuild,v 1.1 2005/08/10 14:00:53 phosphan Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="C subroutine library for computing the Discrete Fourier Transform (DFT)"
+HOMEPAGE="http://www.fftw.org/"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc x86"
+IUSE="3dnow altivec mpi sse sse2"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${WORKDIR}/${P}"
+ epatch ${FILESDIR}/3-tmpfile.patch
+ cd "${WORKDIR}"
+ use ppc-macos && epatch ${FILESDIR}/${PN}-ppc-macos.patch
+ mv ${P} ${P}-single
+ cp -a ${P}-single ${P}-double
+}
+
+src_compile() {
+ #-fpmath=xx is reported to cause trouble on pentium4 m series
+ #(for 3.0.x: this sort of thing should be handled by the --enable-sse
+ #style configure flags. these are set below using the use variables,
+ #but under gcc-3.2.x, sse2 seems to cause trouble.)
+ filter-mfpmath
+
+ # in gcc 3.2.3 at least, using sse or sse2 causes trouble with -O3
+ # according to the docs, -O0 can cause trouble too! So pending further
+ # testing, ...
+ if use sse; then
+ filter-flags -O3 -O1 -O -Os
+ append-flags -O2
+ fi
+
+ local myconf=""
+ local myconfsingle=""
+ local myconfdouble=""
+
+ use mpi && myconf="${myconf} --enable-mpi"
+ #mpi is not a valid flag yet. In this revision it is used merely to block --enable-mpi option
+ #it might be needed if it is decided that lam is an optional dependence
+
+ if use sse2; then
+ myconfsingle="$myconfsingle --enable-sse"
+ myconfdouble="$myconfdouble --enable-sse2"
+ elif use sse; then
+ myconfsingle="$myconfsingle --enable-sse"
+ elif use 3dnow; then
+ myconfsingle="$myconfsingle --enable-k7"
+ fi
+
+ # Altivec-support in fftw is currently broken
+ # with gcc 3.4
+ if [ "`gcc-version`" != "3.4" ]; then
+ myconfsingle="$myconfsingle `use_enable altivec`"
+ fi
+
+ cd "${S}-single"
+ econf \
+ --enable-shared \
+ --enable-threads \
+ --enable-float \
+ ${myconf} ${myconfsingle} || die "./configure failed"
+ emake || die
+
+ #the only difference here is no --enable-float
+ cd "${S}-double"
+ econf \
+ --enable-shared \
+ --enable-threads \
+ ${myconf} ${myconfdouble} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ #both builds are installed in the same place
+ #libs have distinuguished names; include files, docs etc. identical.
+ cd "${S}-single"
+ make DESTDIR=${D} install || die
+
+ cd "${S}-double"
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ cd "${S}-single"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
+
+ cd doc/html
+ dohtml -r .
+}
diff --git a/sci-libs/fftw/files/3-tmpfile.patch b/sci-libs/fftw/files/3-tmpfile.patch
new file mode 100644
index 000000000000..797d67c22be9
--- /dev/null
+++ b/sci-libs/fftw/files/3-tmpfile.patch
@@ -0,0 +1,16 @@
+--- tools/fftw-wisdom-to-conf.in 2003-07-03 23:56:58.000000000 +0200
++++ tools/fftw-wisdom-to-conf.in.new 2005-08-10 14:17:25.000000000 +0200
+@@ -57,7 +57,7 @@
+ extern void ${prefix}solvtab_exec(const struct solvtab_s s[], void *);
+ EOF
+
+-tmp=/tmp/fftw-wisdom-to-conf$$
++tmp=$(mktemp -t fftw-wisdom-to-conf.XXXXXX) || exit 1
+ sed 's/ *(//' | cut -d" " -f1 | grep -v -- - | egrep -v '^ *\)*$' > $tmp
+
+ cat $tmp | sort | uniq | while read reg_nam; do
+@@ -73,3 +73,4 @@
+
+ echo " ${prefix}solvtab_exec(s, plnr);"
+ echo "}"
++rm $tmp
diff --git a/sci-libs/fftw/files/digest-fftw-3.0.1-r2 b/sci-libs/fftw/files/digest-fftw-3.0.1-r2
new file mode 100644
index 000000000000..0dcc37da443b
--- /dev/null
+++ b/sci-libs/fftw/files/digest-fftw-3.0.1-r2
@@ -0,0 +1 @@
+MD5 76cd21ecc9a7bed6343566c473c36477 fftw-3.0.1.tar.gz 1946361