summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-03 20:10:55 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-03 20:10:55 +0000
commitca9b090ba3ba67dd6ee30bd3305b3c43a327b8a2 (patch)
tree58357393a76d9639c09a168b630c6733ec942aa7 /sci-libs/gpp4/gpp4-1.3.1.ebuild
parentclean up (diff)
downloadhistorical-ca9b090ba3ba67dd6ee30bd3305b3c43a327b8a2.tar.gz
historical-ca9b090ba3ba67dd6ee30bd3305b3c43a327b8a2.tar.bz2
historical-ca9b090ba3ba67dd6ee30bd3305b3c43a327b8a2.zip
New addition, written by me
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/gpp4/gpp4-1.3.1.ebuild')
-rw-r--r--sci-libs/gpp4/gpp4-1.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/gpp4/gpp4-1.3.1.ebuild b/sci-libs/gpp4/gpp4-1.3.1.ebuild
new file mode 100644
index 000000000000..3f49b44b0a35
--- /dev/null
+++ b/sci-libs/gpp4/gpp4-1.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gpp4/gpp4-1.3.1.ebuild,v 1.1 2011/03/03 20:10:55 jlec Exp $
+
+EAPI="4"
+
+DESCRIPTION="A standalone, drop-in replacement for the CCP4 library"
+HOMEPAGE="https://launchpad.net/gpp4"
+SRC_URI="http://launchpad.net/${PN}/1.3/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="fortran static-libs"
+
+RDEPEND="sci-libs/mmdb"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with fortran fortran-api) \
+ $(use_enable static-libs static)
+}