summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-01 17:02:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-01 17:02:07 +0000
commit87a0727ea2115ef5d0e9f98d648c2913a229d151 (patch)
treebe3f685fba74b1b4f7b9ee31d6bc6f04fe449d2b /sci-libs/libnc-dap
parentInitial commit. Ebuild by Oliver Jaksch, closes bug #342181. (diff)
downloadhistorical-87a0727ea2115ef5d0e9f98d648c2913a229d151.tar.gz
historical-87a0727ea2115ef5d0e9f98d648c2913a229d151.tar.bz2
historical-87a0727ea2115ef5d0e9f98d648c2913a229d151.zip
Remove use of fortran eclass
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/libnc-dap')
-rw-r--r--sci-libs/libnc-dap/ChangeLog8
-rw-r--r--sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild61
2 files changed, 36 insertions, 33 deletions
diff --git a/sci-libs/libnc-dap/ChangeLog b/sci-libs/libnc-dap/ChangeLog
index 260fa5971eb0..6ab4c9faba99 100644
--- a/sci-libs/libnc-dap/ChangeLog
+++ b/sci-libs/libnc-dap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libnc-dap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/ChangeLog,v 1.4 2009/05/11 03:50:00 nerdboy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/ChangeLog,v 1.5 2010/12/01 17:02:07 bicatali Exp $
+
+ 01 Dec 2010; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ libnc-dap-3.7.3-r1.ebuild:
+ Remove use of fortran eclass
11 May 2009; Steve Arnold <nerdboy@gentoo.org> libnc-dap-3.7.3-r1.ebuild:
Updated to fix exported symbols with gfortran (one less underscore). Only
diff --git a/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild b/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
index 7c53bb6caf71..4a3f9691d4b7 100644
--- a/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
+++ b/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild,v 1.2 2009/05/11 03:50:00 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild,v 1.3 2010/12/01 17:02:07 bicatali Exp $
-inherit eutils flag-o-matic fortran
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="An OPeNDAP-enabled version of the NetCDF 3.6 API that replaces the standard NetCDF library."
HOMEPAGE="http://opendap.org/index.html"
@@ -24,19 +24,18 @@ DEPEND="${RDEPEND}
pkg_setup() {
if use fortran; then
- fortran_pkg_setup
- case "${FORTRANC}" in
+ case "$(tc-getFC)" in
# probably needs more compilers here, of which I have
# none, so feel free to provide flags for others...
- g77)
+ *g77)
export FCLAGS+="-finit-local-zero -fno-automatic \
- -fno-second-underscore -std=legacy -ff2c \
- -fall-intrinsics -static-libgfortran"
+ -fno-second-underscore -std=legacy -ff2c \
+ -fall-intrinsics -static-libgfortran"
;;
*)
export FCLAGS+="-finit-local-zero -fno-automatic \
- -fno-second-underscore -std=gnu \
- -fall-intrinsics -static-libgfortran"
+ -fno-second-underscore -std=gnu \
+ -fall-intrinsics -static-libgfortran"
;;
esac
else
@@ -44,12 +43,12 @@ pkg_setup() {
fi
if use full-test; then
- if [ -n "${DAP_TEST_OPTS}" ]; then
+ if [ -n "${DAP_TEST_OPTS}" ]; then
elog "User-specified test URL is ${DAP_TEST_OPTS}."
- else
+ else
elog "User-specified test URL is not set; if needed, set"
elog "DAP_TEST_OPTS to a URL of your choice and rebuild."
- fi
+ fi
elog
elog "The full regression test does two passes, the second one with"
elog "remote data queries. The latter part can take several hours,"
@@ -63,16 +62,16 @@ src_unpack() {
cd "${S}"
# increase the number of open netcdf files
sed -i -e "s:MAX_NC_OPEN 32:MAX_NC_OPEN 128:g" \
- lnetcdf/{lnetcdf.h,netcdf.h} \
- || die "sed headers failed"
+ lnetcdf/{lnetcdf.h,netcdf.h} \
+ || die "sed headers failed"
# missing definition causes unknown symbol errors
epatch "${FILESDIR}"/${P}_template-fix.patch
# this is specific to GNU Fortran
- if [[ ${FORTRANC} = gfortran ]] ; then
- elog "updating for gfortran..."
- sed -i -e "s/= -Df2cFortran/= -DgFortran/" Makefile.in \
+ if [[ $(tc-getFC) = *gfortran ]] ; then
+ elog "updating for gfortran..."
+ sed -i -e "s/= -Df2cFortran/= -DgFortran/" Makefile.in \
|| die "sed makefile.in failed"
fi
}
@@ -80,7 +79,7 @@ src_unpack() {
src_compile() {
local test_conf="${DAP_TEST_OPTS}"
local myconf="--disable-dependency-tracking --enable-largefile \
- --enable-64bit"
+ --enable-64bit"
use fortran || myconf="${myconf} --disable-f77"
# debug can be set to 2 for extra verbosity
use debug && myconf="${myconf} --enable-debug=1"
@@ -92,19 +91,19 @@ src_compile() {
src_test() {
if use full-test; then
- cd "${S}"/nc_test
- # These tests should all pass, but the non-local tests can take
- # several hours to complete.
- make check || die "Regression tests failed!"
- cd "${S}"
- # This test has unexpected failures
- make check
+ cd "${S}"/nc_test
+ # These tests should all pass, but the non-local tests can take
+ # several hours to complete.
+ make check || die "Regression tests failed!"
+ cd "${S}"
+ # This test has unexpected failures
+ make check
else
- # unit tests only
- cd "${S}"/unit-tests
- ln -sf ../ncdump/testsuite testsuite
- # These tests should also pass
- make check || die "Unit tests failed!"
+ # unit tests only
+ cd "${S}"/unit-tests
+ ln -sf ../ncdump/testsuite testsuite
+ # These tests should also pass
+ make check || die "Unit tests failed!"
fi
}