summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 18:29:26 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 18:29:26 +0000
commite93b79880e1af86bf02c7b5c83f47a8e263580ff (patch)
treeb5275b209a3a7b9bbcf673cd4d89fb5e38a97a65 /sci-libs/netcdf/netcdf-3.5.0-r4.ebuild
parentMoving to sci-libs/netcdf (diff)
downloadhistorical-e93b79880e1af86bf02c7b5c83f47a8e263580ff.tar.gz
historical-e93b79880e1af86bf02c7b5c83f47a8e263580ff.tar.bz2
historical-e93b79880e1af86bf02c7b5c83f47a8e263580ff.zip
Moved from app-sci/netcdf to sci-libs/netcdf.
Diffstat (limited to 'sci-libs/netcdf/netcdf-3.5.0-r4.ebuild')
-rw-r--r--sci-libs/netcdf/netcdf-3.5.0-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/netcdf/netcdf-3.5.0-r4.ebuild b/sci-libs/netcdf/netcdf-3.5.0-r4.ebuild
new file mode 100644
index 000000000000..345ae17b2f08
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-3.5.0-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.5.0-r4.ebuild,v 1.1 2004/12/28 18:29:26 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
+HOMEPAGE="http://www.unidata.ucar.edu/packages/netcdf/"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~sparc ~amd64 alpha ~ia64 ~ppc ~mips ~hppa"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # welcome to ANSI C++ coding with sed
+ sed \
+ -e 's/iostream\.h/iostream/g' \
+ -e 's/cout/std::cout/g' \
+ -e 's/^extern "C".*//g' -i configure || die
+
+ epatch ${FILESDIR}/fPIC.patch
+ cd cxx && epatch ${FILESDIR}/gcc3-gentoo.patch
+}
+
+src_compile() {
+ export CPPFLAGS=-Df2cFortran
+ econf || die "econf failed"
+ make || die
+ make test || die
+}
+
+src_install() {
+ dodir /usr/{lib,share} /usr/share/man/man3 /usr/share/man/man3f
+ einstall MANDIR=${D}/usr/share/man
+ mv ${D}/usr/share/man/man3/netcdf.3f ${D}/usr/share/man/man3f/.
+ dodoc COMPATIBILITY COPYRIGHT MANIFEST README RELEASE_NOTES VERSION fortran/cfortran.doc
+ dohtml -r .
+}