summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-02 04:40:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-02 04:40:06 +0000
commite6ba788b5bbb5d48faf4fb809e7fea7ae9d9f8c2 (patch)
treee49d86a39b31d8f55223f77f87ba15643877e172 /sci-libs/torch/torch-3.ebuild
parentAdd kernel description file (diff)
downloadhistorical-e6ba788b5bbb5d48faf4fb809e7fea7ae9d9f8c2.tar.gz
historical-e6ba788b5bbb5d48faf4fb809e7fea7ae9d9f8c2.tar.bz2
historical-e6ba788b5bbb5d48faf4fb809e7fea7ae9d9f8c2.zip
Added missing backslashes that caused problems with sed. This fixes bug #132728.
Package-Manager: portage-2.1_rc3-r2
Diffstat (limited to 'sci-libs/torch/torch-3.ebuild')
-rw-r--r--sci-libs/torch/torch-3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/torch/torch-3.ebuild b/sci-libs/torch/torch-3.ebuild
index 198c2c7e62be..698a819266aa 100644
--- a/sci-libs/torch/torch-3.ebuild
+++ b/sci-libs/torch/torch-3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.3 2005/08/24 16:28:34 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.4 2006/06/02 04:40:06 markusle Exp $
inherit toolchain-funcs multilib
@@ -47,7 +47,7 @@ src_install() {
sed -i \
-e "s:^LIBS_DIR.*:LIBS_DIR=/usr/$(get_libdir):" \
-e 's|^INCS := .*|INCS := -I /usr/include/torch $(MYINCS)|' \
- -e '/^INCS +=/c\' \
+ -e '/^INCS +=/c\\' \
Makefile_options_Linux
dodir /usr/share/${PN}
insinto /usr/share/${PN}
@@ -59,7 +59,7 @@ src_install() {
cd ${D}/usr/share/doc/${PF}
sed -i \
-e 's|^TORCHDIR.*|TORCHDIR := /usr/share/torch|' \
- -e '/MAKE/c\' -e '/VERSION_KEY/c\' \
+ -e '/MAKE/c\\' -e '/VERSION_KEY/c\\' \
examples/*/Makefile
for ex in examples/*/Makefile; do
echo -e '\t$(CC) $(CFLAGS_$(MODE)) $(INCS) -o $@ $< $(LIBS)' >> ${ex}