summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-11-06 13:38:48 +0000
committerMichael Januszewski <spock@gentoo.org>2005-11-06 13:38:48 +0000
commit5ac4d0da9c09e552a62dd96fe0f4865ab5153e67 (patch)
tree2986876770ba6e08636d9b835e3d10773963a472 /sci-mathematics/gimps/gimps-24.14-r1.ebuild
parent~amd64 (diff)
downloadhistorical-5ac4d0da9c09e552a62dd96fe0f4865ab5153e67.tar.gz
historical-5ac4d0da9c09e552a62dd96fe0f4865ab5153e67.tar.bz2
historical-5ac4d0da9c09e552a62dd96fe0f4865ab5153e67.zip
Updated the initscript to use start-stop-daemon. Added the option to run mprime as a non-root user (bug #107168).
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sci-mathematics/gimps/gimps-24.14-r1.ebuild')
-rw-r--r--sci-mathematics/gimps/gimps-24.14-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/gimps-24.14-r1.ebuild b/sci-mathematics/gimps/gimps-24.14-r1.ebuild
new file mode 100644
index 000000000000..64c87fd332ef
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-24.14-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-24.14-r1.ebuild,v 1.1 2005/11/06 13:38:48 spock Exp $
+
+IUSE=""
+DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="ftp://mersenne.org/gimps/sprime${PV/./}.tar.gz"
+
+# We have to use the statically linked version since the dynamically
+# linked one requires gcc >= 3.4.4 (stdlibc++.so.6 dependency).
+
+DEPEND=">=sys-apps/baselayout-1.8.0
+ >=sys-libs/glibc-2.1"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="-* ~amd64 ~x86"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+src_install () {
+ cd ${S}
+
+ dodir ${I} /var/lib/gimps
+ cp mprime ${D}/${I}
+ chmod a-w ${D}/${I}/mprime
+ chown root:0 ${D}/${I}
+ chown root:0 ${D}/${I}/mprime
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/gimps-24.14-init.d gimps
+ insinto /etc/conf.d ; newins ${FILESDIR}/gimps-24.14-conf.d gimps
+}
+
+pkg_postinst () {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, eg.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm () {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}