summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-31 21:55:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-31 21:55:05 +0000
commit374d542f93d09ec9e3fa629a58a3682cf61112f9 (patch)
treefb9f4b0fb91642f073f35a722c12866b31bfe48a /sci-mathematics/glpk/glpk-4.42.ebuild
parentInitial import (diff)
downloadhistorical-374d542f93d09ec9e3fa629a58a3682cf61112f9.tar.gz
historical-374d542f93d09ec9e3fa629a58a3682cf61112f9.tar.bz2
historical-374d542f93d09ec9e3fa629a58a3682cf61112f9.zip
Version bump
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics/glpk/glpk-4.42.ebuild')
-rw-r--r--sci-mathematics/glpk/glpk-4.42.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/glpk-4.42.ebuild b/sci-mathematics/glpk/glpk-4.42.ebuild
new file mode 100644
index 000000000000..f01541b7c013
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.42.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.42.ebuild,v 1.1 2010/01/31 21:55:05 bicatali Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
+ econf \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable odbc) \
+ $(use_enable mysql) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
+ if use doc; then
+ cd "${S}"/doc
+ doins *.pdf notes/*.pdf || die "failed to instal djvu and pdf"
+ dodoc *.txt || die "failed to install manual files"
+ fi
+}