summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-10-24 15:48:32 +0000
committerThomas Kahle <tomka@gentoo.org>2010-10-24 15:48:32 +0000
commitbf0939449d3a0033ea1cd600e664d9dc87a1c4ed (patch)
treedfacb43603f02b2d12d04190e5f692c76e922ce9 /sci-mathematics/nauty/nauty-2.4.2.ebuild
parentppc64 stable wrt #341669 (diff)
downloadhistorical-bf0939449d3a0033ea1cd600e664d9dc87a1c4ed.tar.gz
historical-bf0939449d3a0033ea1cd600e664d9dc87a1c4ed.tar.bz2
historical-bf0939449d3a0033ea1cd600e664d9dc87a1c4ed.zip
New package: sci-mathematics/nauty
Migrated from science overlay, fixes bug 337810 Package-Manager: portage-2.1.9.22/cvs/Linux i686
Diffstat (limited to 'sci-mathematics/nauty/nauty-2.4.2.ebuild')
-rw-r--r--sci-mathematics/nauty/nauty-2.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/nauty/nauty-2.4.2.ebuild b/sci-mathematics/nauty/nauty-2.4.2.ebuild
new file mode 100644
index 000000000000..8d629af0b619
--- /dev/null
+++ b/sci-mathematics/nauty/nauty-2.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nauty/nauty-2.4.2.ebuild,v 1.1 2010/10/24 15:48:32 tomka Exp $
+
+EAPI="2"
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 2 'r')
+MY_PV=$(delete_version_separator 1 ${MY_PV})
+
+DESCRIPTION="program for computing automorphism groups of graphs and digraphs."
+HOMEPAGE="http://cs.anu.edu.au/~bdm/nauty/"
+SRC_URI="http://cs.anu.edu.au/~bdm/${PN}/${PN}${MY_PV}.tar.gz"
+
+LICENSE="nauty"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare () {
+ sed -i "s/LDFLAGS=/LDFLAGS=${LDFLAGS}/" makefile.in || die
+}
+
+src_test () {
+ make checks || die "tests failed"
+}
+
+src_install () {
+ dobin addedgeg amtog biplabg catg complg copyg countg \
+ deledgeg directg dreadnaut dretog genbg geng genrang \
+ gentourng labelg listg multig newedgeg NRswitchg pickg \
+ planarg shortg showg || die "install failed"
+ dodoc README formats.txt
+}