summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2005-07-07 13:18:46 +0000
committerGeorge Shapovalov <george@gentoo.org>2005-07-07 13:18:46 +0000
commit1426f92e30d3850939f725192ddb02441df1eec8 (patch)
treefc46240b4d0a9dbd273d1ec4d0d98fe88178a901 /sci-mathematics/pari
parentAdded back cdinstall for d2x. (diff)
downloadhistorical-1426f92e30d3850939f725192ddb02441df1eec8.tar.gz
historical-1426f92e30d3850939f725192ddb02441df1eec8.tar.bz2
historical-1426f92e30d3850939f725192ddb02441df1eec8.zip
-fPIC was needed on amd64 for executables (as well as libs), no -r update as this is acompile time fix
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/Manifest8
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild13
2 files changed, 14 insertions, 7 deletions
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index 96adbb2eb5f4..bea627d9b1a0 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,9 +1,9 @@
+MD5 95d3d69c971b880d9a083f59dcf70bb5 pari-2.1.5-r4.ebuild 2272
+MD5 b280810de2c9996b6da854bc3a813bc7 pari-2.1.6.ebuild 2240
MD5 d77daee6115ce4c944cfc2a8770e2fb8 ChangeLog 4826
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 95d3d69c971b880d9a083f59dcf70bb5 pari-2.1.5-r4.ebuild 2272
-MD5 627fadd2aa9ad53161b00d5452ba034d pari-2.1.6.ebuild 2028
+MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r4 63
+MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
MD5 2fd9906f2bf293fdad42d572846508de files/digest-pari-2.1.6 60
-MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
-MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index 7e72d2d991fd..b77b4828e5b8 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.11 2005/05/31 09:48:40 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.12 2005/07/07 13:18:46 george Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
HOMEPAGE="http://pari.math.u-bordeaux.fr/"
@@ -25,6 +25,7 @@ src_unpack() {
src_compile() {
# Fix usage of toolchain
tc-getAS; tc-getLD; tc-getCC; tc-getCXX
+
./Configure \
--host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
--prefix=/usr \
@@ -47,8 +48,14 @@ src_compile() {
einfo "Building shared library..."
cd Olinux-* || die "Bad directory. File a BUG!"
emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+
einfo "Building executables..."
- emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+ #-fPIC seems to be needed here as well on amd64
+ if [ "${ARCH}" = "amd64" ]; then
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" gp ../gp || die "Building executables failed!"
+ else
+ emake ${mymake} CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+ fi
use doc || rm -rf doc/*.tex
use doc && emake doc