summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-04 01:33:03 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-04 01:33:03 +0000
commit0356fe7432182a634e2a563225fb0b8b62140a73 (patch)
tree38743a8f17463ce7656dcad3923debf167cf440a /sci-mathematics/yacas/yacas-1.0.63.ebuild
parentfix digestentry.unused (diff)
downloadhistorical-0356fe7432182a634e2a563225fb0b8b62140a73.tar.gz
historical-0356fe7432182a634e2a563225fb0b8b62140a73.tar.bz2
historical-0356fe7432182a634e2a563225fb0b8b62140a73.zip
Added patch to fix the as-needed linking issues (see bug #167438).
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'sci-mathematics/yacas/yacas-1.0.63.ebuild')
-rw-r--r--sci-mathematics/yacas/yacas-1.0.63.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sci-mathematics/yacas/yacas-1.0.63.ebuild b/sci-mathematics/yacas/yacas-1.0.63.ebuild
index 1721f4e0a765..bdd75a128279 100644
--- a/sci-mathematics/yacas/yacas-1.0.63.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.63.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.2 2007/01/29 16:09:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.3 2007/05/04 01:33:03 markusle Exp $
-inherit eutils flag-o-matic
+inherit autotools eutils flag-o-matic
IUSE="glut server"
@@ -23,11 +23,16 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
cd "${S}"
+
if ! use glut; then
- sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's:opengl::g' -i plugins/Makefile.am || \
+ die "sed (opengl) failed"
sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
- manmake/Makefile.in || die 'sed (manmake) failed'
+ manmake/Makefile.am || die 'sed (manmake) failed'
fi
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
}
src_compile() {