summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-01-28 13:34:29 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-01-28 13:34:29 +0000
commit94b15238b1c408a9a6435eda78ffdadd57e3c1b5 (patch)
tree1506bb4f03c0fe718aea9f152e31860d76668e85 /sci-mathematics/yacas/yacas-1.0.63.ebuild
parentAdd ~amd64 and ~x86-fbsd keywords. (diff)
downloadhistorical-94b15238b1c408a9a6435eda78ffdadd57e3c1b5.tar.gz
historical-94b15238b1c408a9a6435eda78ffdadd57e3c1b5.tar.bz2
historical-94b15238b1c408a9a6435eda78ffdadd57e3c1b5.zip
Version bump with several enhancements (see #159313).
Package-Manager: portage-2.1.2-r4
Diffstat (limited to 'sci-mathematics/yacas/yacas-1.0.63.ebuild')
-rw-r--r--sci-mathematics/yacas/yacas-1.0.63.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-mathematics/yacas/yacas-1.0.63.ebuild b/sci-mathematics/yacas/yacas-1.0.63.ebuild
new file mode 100644
index 000000000000..21268c6cb8b8
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.0.63.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.1 2007/01/28 13:34:29 markusle Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="glut server proteus"
+
+DESCRIPTION="very powerful general purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ dev-lang/perl
+ glut? ( virtual/glut )
+ proteus? ( x11-libs/fltk )
+ www-client/lynx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use glut; then
+ sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
+ manmake/Makefile.in || die 'sed (manmake) failed'
+ fi
+}
+
+src_compile() {
+ # Filter -Os due to reported issues with it in bug 126779.
+ replace-flags -Os -O2
+
+ local myconf="--with-numlib=native"
+
+ if use server; then
+ myconf="${myconf} --enable-server"
+ fi
+
+ if use proteus; then
+ myconf="${myconf} --enable-proteus"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ cd "${S}"
+ make DESTDIR="${D}" install-strip || die
+
+ dodoc AUTHORS INSTALL NEWS README TODO
+ mv "${D}"/usr/share/${PN}/documentation "${D}"/usr/share/doc/${PF}/html
+ rmdir "${D}"/usr/include/
+ rm "${D}"/usr/share/${PN}/include/win32*
+ sed -e "s|\":FindFile(\"documentation/ref.html\"):\"|localhost/usr/share/doc/${PF}/html/ref.html|" \
+ -e "s|\":FindFile(\"documentation/books.html\"):\"|localhost/usr/share/doc/${PF}/html/books.html|" \
+ -i "${D}"/usr/share/${PN}/yacasinit.ys || die
+}