summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-10 16:34:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-10 16:34:37 +0000
commitf542bf0909f676c6b3cc0d1a9ebc2d75c71f371e (patch)
tree594b44c9c088c855dcf6d4ad30d96276cb4d0354 /sci-physics/geant-data/geant-data-4.9.6_p02.ebuild
parentInitial import, split from sci-physics/geant:4 (diff)
downloadhistorical-f542bf0909f676c6b3cc0d1a9ebc2d75c71f371e.tar.gz
historical-f542bf0909f676c6b3cc0d1a9ebc2d75c71f371e.tar.bz2
historical-f542bf0909f676c6b3cc0d1a9ebc2d75c71f371e.zip
Initial import, split from sci-physics/geant:4
Package-Manager: portage-2.2.01.21938-prefix/cvs/Linux x86_64 Manifest-Sign-Key: 0x13CB1360
Diffstat (limited to 'sci-physics/geant-data/geant-data-4.9.6_p02.ebuild')
-rw-r--r--sci-physics/geant-data/geant-data-4.9.6_p02.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-physics/geant-data/geant-data-4.9.6_p02.ebuild b/sci-physics/geant-data/geant-data-4.9.6_p02.ebuild
new file mode 100644
index 000000000000..e0b0a6010251
--- /dev/null
+++ b/sci-physics/geant-data/geant-data-4.9.6_p02.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant-data/geant-data-4.9.6_p02.ebuild,v 1.1 2013/06/10 16:34:20 bicatali Exp $
+
+EAPI=5
+
+DESCRIPTION="Data files for Geant4 physical processes"
+HOMEPAGE="http://geant4.cern.ch/"
+
+NDLPV=4.2
+GEANT4_DATA="
+ G4NDL.${NDLPV}
+ G4EMLOW.6.32
+ G4RadioactiveDecay.3.6
+ G4SAIDDATA.1.1
+ G4NEUTRONXS.1.2
+ G4PII.1.3
+ G4PhotonEvaporation.2.3
+ G4ABLA.3.0
+ RealSurface.1.0"
+
+SRC_URI="${SRC_COM}/G4NDL${NDLPV}.TS.tar.gz"
+SRC_COM="http://geant4.cern.ch/support/source"
+for d in ${GEANT4_DATA}; do
+ SRC_URI="${SRC_URI} ${SRC_COM}/${d}.tar.gz"
+done
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="~sci-physics/geant-${PV}:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ for d in ${GEANT4_DATA}; do
+ local p=${d/.}
+ doins -r *${p/G4}
+ done
+ sed -n "s,export \(G4.\+DATA=\"\).*\(/share/Geant.\+/data/.\+\) > /dev/null ; pwd\`,\1${EROOT%/}/usr\2,p" \
+ "${EROOT}/usr/bin/geant4.sh" > 99geant-data
+ doenvd 99geant-data
+}