summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-12-18 07:13:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-12-18 07:13:05 +0000
commit115a79ef1fab561cb2d075203db12594be689bb4 (patch)
tree00cdfe85d67e725c54cb460c4c2bb261307fb43e /sci-physics/geant/files
parentVersion bump. (diff)
downloadhistorical-115a79ef1fab561cb2d075203db12594be689bb4.tar.gz
historical-115a79ef1fab561cb2d075203db12594be689bb4.tar.bz2
historical-115a79ef1fab561cb2d075203db12594be689bb4.zip
Version bumps. Re-introduced some older flags and fixed linking of zlib. Added patch for source trajectory example (bug #365171), thanks Matthias Nagl.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'sci-physics/geant/files')
-rw-r--r--sci-physics/geant/files/geant-4.9.4-trajectory.patch11
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch31
2 files changed, 31 insertions, 11 deletions
diff --git a/sci-physics/geant/files/geant-4.9.4-trajectory.patch b/sci-physics/geant/files/geant-4.9.4-trajectory.patch
new file mode 100644
index 000000000000..df45ae234e50
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-trajectory.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2011-04-28 01:19:54.232041312 +0200
++++ CMakeLists.txt 2011-04-28 01:15:11.434101391 +0200
+@@ -43,6 +43,8 @@
+ set(${PROJECT_NAME}_VERSION_MINOR "4")
+ set(${PROJECT_NAME}_VERSION_PATCH "1")
+
++add_definitions(-DG4_STORE_TRAJECTORY)
++
+ #------------------------------------------------------------------------------
+ # Set up path to internal set of CMake modules.
+ #
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
index faa850e214ae..ac7b72818be9 100644
--- a/sci-physics/geant/files/geant-4.9.4-zlib.patch
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -1,11 +1,20 @@
---- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
-+++ CMakeLists.txt 2011-01-17 06:25:26.166078780 +0000
-@@ -154,7 +154,7 @@
- #------------------------------------------------------------------------------
- # Optional use of system zlib library
- #
--#option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
-+option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
- if(GEANT4_USE_SYSTEM_ZLIB)
- # This needs more work - use ITK's way of doing it as an example.
- find_package(ZLIB)
+--- source/visualization/HepRep/sources.cmake.orig 2011-12-02 15:07:49.000000000 +0000
++++ source/visualization/HepRep/sources.cmake 2011-12-18 06:21:22.000000000 +0000
+@@ -91,7 +91,7 @@
+ G4specsolids
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+ G4digits_hits
+ G4geometry
+@@ -102,7 +102,7 @@
+ G4modeling
+ G4tracking
+ G4vis_management
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ )
+