summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 16:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 16:07:47 +0000
commitae971116ab324ce07dadccb4a20bd91976737c89 (patch)
tree0ec81b8e78fc0694ad5cc21bd9e1a7c432e67443 /sys-apps/acpid
parentBuild fix. See bug #55393. (diff)
downloadhistorical-ae971116ab324ce07dadccb4a20bd91976737c89.tar.gz
historical-ae971116ab324ce07dadccb4a20bd91976737c89.tar.bz2
historical-ae971116ab324ce07dadccb4a20bd91976737c89.zip
change glibc to libc
Diffstat (limited to 'sys-apps/acpid')
-rw-r--r--sys-apps/acpid/acpid-1.0.1.ebuild19
-rw-r--r--sys-apps/acpid/acpid-1.0.2-r1.ebuild18
-rw-r--r--sys-apps/acpid/acpid-1.0.2-r2.ebuild20
3 files changed, 26 insertions, 31 deletions
diff --git a/sys-apps/acpid/acpid-1.0.1.ebuild b/sys-apps/acpid/acpid-1.0.1.ebuild
index c2c8d1a577a9..2c154f61785e 100644
--- a/sys-apps/acpid/acpid-1.0.1.ebuild
+++ b/sys-apps/acpid/acpid-1.0.1.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.1.ebuild,v 1.14 2004/06/24 21:57:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.1.ebuild,v 1.15 2004/06/28 15:57:44 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
-SRC_URI="ftp://download.sourceforge.net/pub/sourceforge/acpid/${P}.tar.gz"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
HOMEPAGE="http://acpid.sourceforge.net/"
-KEYWORDS="x86 amd64 -ppc"
-SLOT="0"
+SRC_URI="ftp://download.sourceforge.net/pub/sourceforge/acpid/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
# We need the patched kernel with latest ACPI code, or else it will
# be broken. Hopefully it will be merge into release kernel soon.
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/linux-sources"
src_compile() {
-
# DO NOT compile with optimizations !
make INSTPREFIX=${D} ||die
}
-src_install () {
-
+src_install() {
make INSTPREFIX=${D} install || die
dodir /etc/acpi/events
diff --git a/sys-apps/acpid/acpid-1.0.2-r1.ebuild b/sys-apps/acpid/acpid-1.0.2-r1.ebuild
index 915d759c9bf5..3a856ced19ed 100644
--- a/sys-apps/acpid/acpid-1.0.2-r1.ebuild
+++ b/sys-apps/acpid/acpid-1.0.2-r1.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r1.ebuild,v 1.5 2004/06/24 21:57:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r1.ebuild,v 1.6 2004/06/28 15:57:44 vapier Exp $
-S="${WORKDIR}/${P}"
-DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
-SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
HOMEPAGE="http://acpid.sourceforge.net/"
-IUSE=""
-KEYWORDS="x86 amd64 -ppc"
-SLOT="0"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
# We need the patched kernel with latest ACPI code, or else it will
# be broken. Hopefully it will be merge into release kernel soon.
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/linux-sources"
src_compile() {
-
# DO NOT COMPILE WITH OPTIMISATIONS.
# That is a note to the devs. IF you are a user, go ahead and optimise
# if you want, but we won't support bugs associated with that"
@@ -38,4 +37,3 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/acpid.rc6 acpid
}
-
diff --git a/sys-apps/acpid/acpid-1.0.2-r2.ebuild b/sys-apps/acpid/acpid-1.0.2-r2.ebuild
index aa9ea5f82360..932e946f4cd5 100644
--- a/sys-apps/acpid/acpid-1.0.2-r2.ebuild
+++ b/sys-apps/acpid/acpid-1.0.2-r2.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r2.ebuild,v 1.6 2004/06/24 21:57:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpid/acpid-1.0.2-r2.ebuild,v 1.7 2004/06/28 15:57:44 vapier Exp $
inherit eutils
-S="${WORKDIR}/${P}"
-DESCRIPTION="Daemon for Advanced Configuration and Power Interface."
-SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
HOMEPAGE="http://acpid.sourceforge.net/"
-IUSE=""
-KEYWORDS="x86 amd64 -ppc alpha ia64"
-SLOT="0"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc alpha amd64 ia64"
+IUSE=""
# We need the patched kernel with latest ACPI code, or else it will
# be broken. Hopefully it will be merge into release kernel soon.
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/linux-sources"
src_compile() {
-
# Fix bug # 22238 (default.sh broken)
- ( cd debian && epatch ${FILESDIR}/default.sh-gentoo.patch )
+ cd debian && epatch ${FILESDIR}/default.sh-gentoo.patch && cd ..
# DO NOT COMPILE WITH OPTIMISATIONS.
# That is a note to the devs. IF you are a user, go ahead and optimise
@@ -43,4 +42,3 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/acpid.rc6 acpid
}
-