summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-20 00:05:38 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-20 00:05:38 +0000
commitae15bfbb13d1ba05c3cdf68901ba4dd879d66364 (patch)
tree53562f906cdf012882a0005e0bba43e62fd6cc8e /sys-apps/at
parentfixed linking issue (binutils-related). Upgrade not necessary unless your (diff)
downloadhistorical-ae15bfbb13d1ba05c3cdf68901ba4dd879d66364.tar.gz
historical-ae15bfbb13d1ba05c3cdf68901ba4dd879d66364.tar.bz2
historical-ae15bfbb13d1ba05c3cdf68901ba4dd879d66364.zip
new at
Diffstat (limited to 'sys-apps/at')
-rw-r--r--sys-apps/at/at-3.1.8-r7.ebuild51
-rw-r--r--sys-apps/at/files/digest-at-3.1.8-r71
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/at/at-3.1.8-r7.ebuild b/sys-apps/at/at-3.1.8-r7.ebuild
new file mode 100644
index 000000000000..280ff22b752f
--- /dev/null
+++ b/sys-apps/at/at-3.1.8-r7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Ferry Meyndert <m0rpheus@poseidon.mine.nu>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/at/at-3.1.8-r7.ebuild,v 1.1 2002/01/20 00:05:38 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Queues jobs for later execution"
+SRC_URI="http://ftp.debian.org/debian/pool/main/a/at/at_${PV}-11.tar.gz"
+HOMEPAGE=""
+
+DEPEND="virtual/glibc >=sys-devel/flex-2.5.4a"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure --host=${CHOST/-pc/} --sysconfdir=/etc/at \
+ --with-jobdir=/var/cron/atjobs \
+ --with-atspool=/var/cron/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at || die
+ emake || die
+}
+
+src_install() {
+
+ into /usr
+ chmod 755 batch
+ chmod 755 atrun
+ dobin at batch
+ fperms 4755 /usr/bin/at
+ dosym at /usr/bin/atrm
+ dosym at /usr/bin/atq
+ dosbin atd atrun
+
+ for i in atjobs atspool
+ do
+ dodir /var/cron/${i}
+ fperms 700 /var/cron/${i}
+ fowners at.at /var/cron/${i}
+ touch ${D}/var/cron/${i}/.SEQ
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/atd.rc6 atd
+ insinto /etc/at
+ insopts -m 0644
+ doins ${FILESDIR}/at.deny
+ doman at.1 at_allow.5 atd.8 atrun.8
+ dodoc COPYING ChangeLog Copyright Problems README
+}
diff --git a/sys-apps/at/files/digest-at-3.1.8-r7 b/sys-apps/at/files/digest-at-3.1.8-r7
new file mode 100644
index 000000000000..4869504a6644
--- /dev/null
+++ b/sys-apps/at/files/digest-at-3.1.8-r7
@@ -0,0 +1 @@
+MD5 81dbae5162aaa8a398a81424d6631c77 at_3.1.8-11.tar.gz 110592