summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-23 03:57:02 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-23 03:57:02 +0000
commit1fb615d38be321ed0faa9549669659ca0c90ce54 (patch)
tree5e751f049e1607818831f5bb51698e7565d7b35d /sys-apps/attr/attr-2.4.41.ebuild
parentold (diff)
downloadhistorical-1fb615d38be321ed0faa9549669659ca0c90ce54.tar.gz
historical-1fb615d38be321ed0faa9549669659ca0c90ce54.tar.bz2
historical-1fb615d38be321ed0faa9549669659ca0c90ce54.zip
Make sure we respect LINGUAS #205952 by Arvid Norlander and version bump #211113.
Package-Manager: portage-2.2_pre2
Diffstat (limited to 'sys-apps/attr/attr-2.4.41.ebuild')
-rw-r--r--sys-apps/attr/attr-2.4.41.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-2.4.41.ebuild b/sys-apps/attr/attr-2.4.41.ebuild
new file mode 100644
index 000000000000..b4fb47310b59
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.41.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.41.ebuild,v 1.1 2008/02/23 03:57:01 vapier Exp $
+
+inherit eutils autotools toolchain-funcs
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4.39-gettext.patch
+ epatch "${FILESDIR}"/${PN}-2.4.39-linguas.patch #205948
+ epatch "${FILESDIR}"/${PN}-2.4.24-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ # libtool will clobber install-sh which is really a custom file
+ mv install-sh acl.install-sh || die
+ AT_M4DIR="m4" eautoreconf
+ mv acl.install-sh install-sh || die
+ strip-linguas po
+}
+
+src_compile() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libattr.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libattr.so
+}