summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Færøy <eroyf@gentoo.org>2006-12-17 22:05:49 +0000
committerAlexander Færøy <eroyf@gentoo.org>2006-12-17 22:05:49 +0000
commit66ad3220c177f3aa283882591f0f56df61cbfb61 (patch)
treea04ffee888f6a465f18284955ff5eb5dd0c6a178 /sys-apps/dbus/files
parentStable on hppa. See bug #152783. (diff)
downloadhistorical-66ad3220c177f3aa283882591f0f56df61cbfb61.tar.gz
historical-66ad3220c177f3aa283882591f0f56df61cbfb61.tar.bz2
historical-66ad3220c177f3aa283882591f0f56df61cbfb61.zip
Regenerating 0.61-r1 with mips stable only.
Package-Manager: portage-2.1.2_rc3-r5
Diffstat (limited to 'sys-apps/dbus/files')
-rw-r--r--sys-apps/dbus/files/dbus-0.60-decls-ansi-c.patch19
-rw-r--r--sys-apps/dbus/files/dbus-0.60-mono-return-null-fix.diff22
-rw-r--r--sys-apps/dbus/files/dbus-0.60-qt-pc.patch59
-rw-r--r--sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch11
-rw-r--r--sys-apps/dbus/files/dbus-0.61-libxml-dep.patch20
-rw-r--r--sys-apps/dbus/files/dbus-0.61-qt-disabling.patch21
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.61-r13
7 files changed, 155 insertions, 0 deletions
diff --git a/sys-apps/dbus/files/dbus-0.60-decls-ansi-c.patch b/sys-apps/dbus/files/dbus-0.60-decls-ansi-c.patch
new file mode 100644
index 000000000000..9fdb91a3327e
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.60-decls-ansi-c.patch
@@ -0,0 +1,19 @@
+--- dbus/dbus-arch-deps.h.in.orig 2006-02-20 01:09:05.000000000 -0600
++++ dbus/dbus-arch-deps.h.in 2006-02-20 01:09:23.000000000 -0600
+@@ -29,7 +29,7 @@
+
+ #include <dbus/dbus-macros.h>
+
+-DBUS_BEGIN_DECLS;
++DBUS_BEGIN_DECLS
+
+ #if @DBUS_HAVE_INT64@
+ #define DBUS_HAVE_INT64 1
+@@ -51,6 +51,6 @@
+ typedef @DBUS_INT16_TYPE@ dbus_int16_t;
+ typedef unsigned @DBUS_INT16_TYPE@ dbus_uint16_t;
+
+-DBUS_END_DECLS;
++DBUS_END_DECLS
+
+ #endif /* DBUS_ARCH_DEPS_H */
diff --git a/sys-apps/dbus/files/dbus-0.60-mono-return-null-fix.diff b/sys-apps/dbus/files/dbus-0.60-mono-return-null-fix.diff
new file mode 100644
index 000000000000..af7fed7fe6ae
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.60-mono-return-null-fix.diff
@@ -0,0 +1,22 @@
+--- mono/Connection.cs.old 2006-02-07 18:13:30.886925672 +0100
++++ mono/Connection.cs 2006-02-07 18:14:07.426370832 +0100
+@@ -116,7 +116,7 @@
+ // Maybe we already have a Connection object associated with
+ // this rawConnection then return it
+ IntPtr rawThis = dbus_connection_get_data (rawConnection, slot);
+- if (rawThis != IntPtr.Zero) {
++ if (rawThis != IntPtr.Zero && ((GCHandle)rawThis).Target == typeof(DBus.Connection)) {
+ return (DBus.Connection) ((GCHandle)rawThis).Target;
+ }
+ }
+--- mono/Message.cs.old 2006-02-07 18:11:27.917619848 +0100
++++ mono/Message.cs 2006-02-07 18:12:36.628174256 +0100
+@@ -110,7 +110,7 @@
+ if (slot > -1) {
+ // If we already have a Message object associated with this rawMessage then return it
+ IntPtr rawThis = dbus_message_get_data(rawMessage, slot);
+- if (rawThis != IntPtr.Zero)
++ if (rawThis != IntPtr.Zero && ((GCHandle)rawThis).Target == typeof(DBus.Message))
+ return (DBus.Message) ((GCHandle)rawThis).Target;
+ }
+ // If it doesn't exist then create a new Message around it
diff --git a/sys-apps/dbus/files/dbus-0.60-qt-pc.patch b/sys-apps/dbus/files/dbus-0.60-qt-pc.patch
new file mode 100644
index 000000000000..a0dcd5ecaa10
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.60-qt-pc.patch
@@ -0,0 +1,59 @@
+diff -Nur dbus-0.60/Makefile.am dbus-0.60-new/Makefile.am
+--- dbus-0.60/Makefile.am 2005-09-30 11:20:08.000000000 -0400
++++ dbus-0.60-new/Makefile.am 2006-01-02 03:15:23.000000000 -0500
+@@ -6,10 +6,12 @@
+
+ if HAVE_QT
+ QT_SUBDIR=qt
++ QT_PC=dbus-qt-1.pc
+ endif
+
+ if HAVE_QT3
+ QT3_SUBDIR=qt3
++ QT_PC=dbus-qt-1.pc
+ endif
+
+ if DBUS_USE_GCJ
+@@ -36,12 +38,13 @@
+ DIST_SUBDIRS=dbus bus doc glib qt qt3 gcj mono python tools test
+
+ pkgconfigdir = $(libdir)/pkgconfig
+-pkgconfig_DATA = dbus-1.pc $(GLIB_PC) $(MONO_PC)
++pkgconfig_DATA = dbus-1.pc $(GLIB_PC) $(MONO_PC) $(QT_PC)
+
+ DISTCLEANFILES = \
+ dbus-1.pc \
+ $(GLIB_PC) \
+- $(MONO_PC)
++ $(MONO_PC) \
++ $(QT_PC)
+
+ EXTRA_DIST = \
+ HACKING \
+diff -Nur dbus-0.60/configure.in dbus-0.60-new/configure.in
+--- dbus-0.60/configure.in 2005-11-22 15:42:49.000000000 -0500
++++ dbus-0.60-new/configure.in 2006-01-02 03:10:40.000000000 -0500
+@@ -1353,6 +1353,7 @@
+ doc/Makefile
+ dbus-1.pc
+ dbus-glib-1.pc
++dbus-qt-1.pc
+ dbus-sharp.pc
+ test/data/valid-config-files/debug-allow-all.conf
+ test/data/valid-config-files/debug-allow-all-sha1.conf
+diff -Nur dbus-0.60/dbus-qt-1.pc.in dbus-0.60-new/dbus-qt-1.pc.in
+--- dbus-0.60/dbus-qt-1.pc.in 1969-12-31 19:00:00.000000000 -0500
++++ dbus-0.60-new/dbus-qt-1.pc.in 2006-01-02 03:10:40.000000000 -0500
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: dbus-qt
++Description: QT integration for the free desktop message bus
++Version: @VERSION@
++Requires: dbus-1 qt-3.3
++Libs: -L${libdir} -ldbus-qt-1
++
++
diff --git a/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
new file mode 100644
index 000000000000..b22d525c8dc4
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-i-hate-qt-so-much.patch
@@ -0,0 +1,11 @@
+--- qt/Makefile.am 2006-02-16 19:04:38.000000000 -0500
++++ qt/Makefile.am.new 2006-03-15 23:39:10.000000000 -0500
+@@ -62,7 +62,7 @@
+ $(top_srcdir)/qt/qdbusserver.lo: qdbusserver.moc
+ $(top_srcdir)/qt/qdbusconnection.lo: qdbusconnection_p.moc
+
+-CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection.moc
++CLEANFILES=qdbusabstractadaptor.moc qdbusserver.moc qdbusconnection_p.moc
+
+ libdbus_qt4_1_la_LIBADD= $(DBUS_QT_LIBS) $(top_builddir)/dbus/libdbus-1.la
+ libdbus_qt4_1_la_LDFLAGS= -version-info 1:0 -no-undefined
diff --git a/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
new file mode 100644
index 000000000000..f7e122f752bb
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-libxml-dep.patch
@@ -0,0 +1,20 @@
+--- configure.in 2006-02-24 11:36:29.000000000 -0500
++++ configure.in.xml 2006-03-15 23:47:31.000000000 -0500
+@@ -9,6 +9,8 @@
+
+ AM_CONFIG_HEADER(config.h)
+
++LIBXML_REQUIRED=2.6.0
++
+ # Honor aclocal flags
+ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+@@ -753,7 +755,7 @@
+ [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ],
+ have_expat=false)
+
+-PKG_CHECK_MODULES(LIBXML, libxml-2.0, have_libxml=true, have_libxml=false)
++PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_REQUIRED, have_libxml=true, have_libxml=false)
+
+ # see what we want to use
+ dbus_use_libxml=false
diff --git a/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
new file mode 100644
index 000000000000..fc270baef346
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.61-qt-disabling.patch
@@ -0,0 +1,21 @@
+--- dbus-0.61/configure.in.disableqt4 2006-02-28 13:33:47.000000000 +0100
++++ dbus-0.61/configure.in 2006-02-28 13:33:29.000000000 +0100
+@@ -1033,6 +1033,10 @@
+ fi
+ have_qt=no
+ else
++ if test x$enable_qt = xno; then
++ have_qt=no;
++ have_qtest=no;
++ else
+ dnl Qt4 flags
+ AC_SUBST(DBUS_QT_CFLAGS)
+ AC_SUBST(DBUS_QT_LIBS)
+@@ -1055,6 +1059,7 @@
+
+ AC_SUBST(DBUS_QTESTLIB_CFLAGS)
+ AC_SUBST(DBUS_QTESTLIB_LIBS)
++ fi
+ fi
+
+ AM_CONDITIONAL(HAVE_QT, test x$have_qt = xyes)
diff --git a/sys-apps/dbus/files/digest-dbus-0.61-r1 b/sys-apps/dbus/files/digest-dbus-0.61-r1
new file mode 100644
index 000000000000..3d8e00466423
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-0.61-r1
@@ -0,0 +1,3 @@
+MD5 cfd4f26004e4304e0dace4d82894e50b dbus-0.61.tar.gz 1735729
+RMD160 67306e1a632c1986460e8ead311ae642447cdcc3 dbus-0.61.tar.gz 1735729
+SHA256 45a6b655c0fdfffdabc49857cb19d1ea0c9a8923f76e5c165e01e18ce98da0ec dbus-0.61.tar.gz 1735729