summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-02 03:25:51 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-02 03:25:51 +0000
commitf61f88c36403bc4dcba8bfc3f0bff35890740976 (patch)
treeb75625bc77cb2646705bd328e5e7d87ad6801b4f /sys-apps/devfsd
parentmiscellaneous doo-dads. (diff)
downloadhistorical-f61f88c36403bc4dcba8bfc3f0bff35890740976.tar.gz
historical-f61f88c36403bc4dcba8bfc3f0bff35890740976.tar.bz2
historical-f61f88c36403bc4dcba8bfc3f0bff35890740976.zip
miscellaneous doo-dads.
Diffstat (limited to 'sys-apps/devfsd')
-rw-r--r--sys-apps/devfsd/devfsd-1.3.20.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/devfsd/devfsd-1.3.20.ebuild b/sys-apps/devfsd/devfsd-1.3.20.ebuild
new file mode 100644
index 000000000000..b8da2746627b
--- /dev/null
+++ b/sys-apps/devfsd/devfsd-1.3.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins et al <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.20.ebuild,v 1.1 2001/12/02 03:25:51 drobbins Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Daemon for the Linux Device Filesystem"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/daemons/devfsd/devfsd-v${PV}.tar.gz"
+HOMEPAGE="http://www.atnf.csiro.au/~rgooch/linux/"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp GNUmakefile GNUmakefile.orig
+ sed -e "s:-O2:${CFLAGS}:g" -e 's:/usr/man:/usr/share/man:' -e '30,32d;8,12d;9d' -e '6c\' -e 'DEFINES := -DLIBNSL="\\"/lib/libnsl.so.1\\""' GNUmakefile.orig > GNUmakefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dodir /sbin /usr/share/man /etc
+ try make PREFIX=${D} install
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/devfsd
+ dodir /dev-state
+ insinto /etc
+ doins ${FILESDIR}/devfsd.conf
+}