summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:51:30 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:51:30 +0000
commit14b1c8046955161d3e7e0f5579d22a4af5bdf67a (patch)
tree4db55c63aa26340f5ffab4679f884eaa9516278d /sys-apps/file
parentfixums (diff)
downloadhistorical-14b1c8046955161d3e7e0f5579d22a4af5bdf67a.tar.gz
historical-14b1c8046955161d3e7e0f5579d22a4af5bdf67a.tar.bz2
historical-14b1c8046955161d3e7e0f5579d22a4af5bdf67a.zip
fixums
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-3.33-r2.ebuild40
-rw-r--r--sys-apps/file/file-3.33-r3.ebuild36
2 files changed, 13 insertions, 63 deletions
diff --git a/sys-apps/file/file-3.33-r2.ebuild b/sys-apps/file/file-3.33-r2.ebuild
deleted file mode 100644
index 06f0a17bc4d8..000000000000
--- a/sys-apps/file/file-3.33-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33-r2.ebuild,v 1.1 2001/02/27 16:29:30 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
-#unfortunately, this ftp site doesn't support passive ftp
-#maybe we can find an alternative for those behind firewalls, or mirror
-#on cvs.gentoo.org
-SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
-
-DEPEND="virtual/glibc"
-
-src_compile() {
-
- try ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/misc --host=${CHOST}
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static
- fi
-}
-
-src_install() {
-
- try make DESTDIR=${D} install
- if [ -z "`use build`" ]
- then
- dodoc LEGAL.NOTICE MAINT README
- else
- rm -rf ${D}/usr/share/man
- fi
-
-}
-
-
-
diff --git a/sys-apps/file/file-3.33-r3.ebuild b/sys-apps/file/file-3.33-r3.ebuild
index 48876dd62a8d..96a0b4ff5393 100644
--- a/sys-apps/file/file-3.33-r3.ebuild
+++ b/sys-apps/file/file-3.33-r3.ebuild
@@ -1,37 +1,27 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33-r3.ebuild,v 1.2 2001/08/04 18:22:45 pete Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33-r3.ebuild,v 1.3 2001/10/06 16:51:30 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
-#unfortunately, this ftp site doesn't support passive ftp
-#maybe we can find an alternative for those behind firewalls, or mirror
-#on cvs.gentoo.org
-SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.bz"
DEPEND="virtual/glibc"
src_compile() {
-
- try ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/misc --host=${CHOST}
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static
- fi
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/misc --host=${CHOST} || die
+ emake || die
}
src_install() {
- try make DESTDIR=${D} install
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- dodoc LEGAL.NOTICE MAINT README
- else
+ make DESTDIR=${D} install || die
+if [ -z "`use build`" ]
+ then
+ dodoc LEGAL.NOTICE MAINT README
+ else
rm -rf ${D}/usr/share/man
- fi
+ fi
}