summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-26 20:08:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-26 20:08:16 +0000
commit9bc242ccfd0ed310e01c7bc86c26f306554f94a5 (patch)
treea35a9da4e80145f88f943e9bbfbbcba75ea890ec /sys-apps/grep
parentuncompress patch for better performance on utf8 systemsbetter performance on ... (diff)
downloadhistorical-9bc242ccfd0ed310e01c7bc86c26f306554f94a5.tar.gz
historical-9bc242ccfd0ed310e01c7bc86c26f306554f94a5.tar.bz2
historical-9bc242ccfd0ed310e01c7bc86c26f306554f94a5.zip
old
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/files/digest-grep-2.5.1-r71
-rw-r--r--sys-apps/grep/grep-2.5.1-r7.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/sys-apps/grep/files/digest-grep-2.5.1-r7 b/sys-apps/grep/files/digest-grep-2.5.1-r7
deleted file mode 100644
index ef03a032aa20..000000000000
--- a/sys-apps/grep/files/digest-grep-2.5.1-r7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 85df024edc9f9689035f6b3de28c7731 grep-2.5.1.tar.gz 683093
diff --git a/sys-apps/grep/grep-2.5.1-r7.ebuild b/sys-apps/grep/grep-2.5.1-r7.ebuild
deleted file mode 100644
index 197f0e129174..000000000000
--- a/sys-apps/grep/grep-2.5.1-r7.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.1-r7.ebuild,v 1.8 2005/05/30 02:41:07 solar Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="GNU regular expression matcher"
-HOMEPAGE="http://www.gnu.org/software/grep/grep.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="build nls pcre static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- pcre? ( dev-libs/libpcre )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix a weird sparc32 compiler bug
- echo "" >> src/dfa.h
-
- epatch "${FILESDIR}"/${PV}-manpage.patch
- epatch "${FILESDIR}"/${PV}-manpage-line-buffering.patch
- epatch "${FILESDIR}"/${P}-fgrep.patch.bz2
- epatch "${FILESDIR}"/${P}-i18n.patch.bz2
- epatch "${FILESDIR}"/${P}-gofast.patch.bz2
- epatch "${FILESDIR}"/${P}-oi.patch.bz2
- epatch "${FILESDIR}"/${P}-restrict_arr.patch
- epatch "${FILESDIR}"/${PV}-utf8-case.patch
-
- # uclibc does not suffer from this glibc bug.
- use elibc_uclibc || epatch "${FILESDIR}"/${PV}-tests.patch
-}
-
-src_compile() {
- if use static ; then
- append-flags -static
- append-ldflags -static
- fi
-
- econf \
- --bindir=/bin \
- $(use_enable nls) \
- $(use_enable pcre perl-regexp) \
- || die "econf failed"
-
- # force static linking so we dont have to move it into /
- sed -i \
- -e 's:-lpcre:-Wl,-Bstatic -lpcre -Wl,-Bdynamic:g' \
- src/Makefile || die "sed static pcre failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # Override the default shell scripts... grep knows how to act
- # based on how it's called
- ln -sfn grep "${D}"/bin/egrep || die "ln egrep failed"
- ln -sfn grep "${D}"/bin/fgrep || die "ln fgrep failed"
-
- if use build ; then
- rm -r "${D}"/usr/share
- else
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
- fi
-}