summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-05-20 21:07:01 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-05-20 21:07:01 +0000
commit807962f6d0d7d65051f1be5578cb688c0e7e5d25 (patch)
tree8697c63f900b6f67de1342f821a8bd2c1cb53cc5 /sys-apps/kbd/kbd-1.06-r1.ebuild
parentAdded fix to ebuild to use CFLAGS in /etc/make.conf. Fixes Bug #21320. (diff)
downloadhistorical-807962f6d0d7d65051f1be5578cb688c0e7e5d25.tar.gz
historical-807962f6d0d7d65051f1be5578cb688c0e7e5d25.tar.bz2
historical-807962f6d0d7d65051f1be5578cb688c0e7e5d25.zip
Added fix to ebuild to use CFLAGS in /etc/make.conf. Fixes Bug #21320.
Diffstat (limited to 'sys-apps/kbd/kbd-1.06-r1.ebuild')
-rw-r--r--sys-apps/kbd/kbd-1.06-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/kbd/kbd-1.06-r1.ebuild b/sys-apps/kbd/kbd-1.06-r1.ebuild
index 20b4170a85c1..fe1dc1c03347 100644
--- a/sys-apps/kbd/kbd-1.06-r1.ebuild
+++ b/sys-apps/kbd/kbd-1.06-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.06-r1.ebuild,v 1.19 2003/02/22 02:18:35 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.06-r1.ebuild,v 1.20 2003/05/20 21:06:44 kumba Exp $
IUSE="nls"
@@ -16,6 +16,12 @@ PROVIDE="sys-apps/console-tools"
src_compile() {
local myopts
+
+ # fixes makefile so that it uses the CFLAGS from portage. Fixes bug #21320
+ cp src/Makefile.in src/Makefile.in.orig
+ sed -e "s:-O2:${CFLAGS}:g" src/Makefile.in.orig > src/Makefile.in
+
+
# non-standard configure script; --di to disable NLS, nothing to enable it.
use nls || myopts="--di"
./configure --mandir=/usr/share/man \