summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-03 23:34:00 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-03 23:34:00 +0000
commit5217be728d89bc7710fe023b6346074ef5edced1 (patch)
treef0a3f5f71de08cd54baa8f35bf7a439f328e95c6 /sys-apps/lm-sensors
parentversion bump (diff)
downloadhistorical-5217be728d89bc7710fe023b6346074ef5edced1.tar.gz
historical-5217be728d89bc7710fe023b6346074ef5edced1.tar.bz2
historical-5217be728d89bc7710fe023b6346074ef5edced1.zip
Version bump to a CVS snapshot which should solve bad temperatures on 2.6.2 kernels.
Diffstat (limited to 'sys-apps/lm-sensors')
-rw-r--r--sys-apps/lm-sensors/ChangeLog8
-rw-r--r--sys-apps/lm-sensors/Manifest4
-rw-r--r--sys-apps/lm-sensors/files/digest-lm-sensors-2.8.3.200402021
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.3.20040202.ebuild138
4 files changed, 149 insertions, 2 deletions
diff --git a/sys-apps/lm-sensors/ChangeLog b/sys-apps/lm-sensors/ChangeLog
index d2b7bd771091..309d1f26ee3f 100644
--- a/sys-apps/lm-sensors/ChangeLog
+++ b/sys-apps/lm-sensors/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lm-sensors
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.18 2004/02/01 23:23:45 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/ChangeLog,v 1.19 2004/02/03 23:34:00 plasmaroo Exp $
+
+*lm-sensors-2.8.3.20040202 (03 Feb 2004)
+
+ 03 Feb 2004; <plasmaroo@gentoo.org> lm-sensors-2.8.3.20040202.ebuild:
+ Version bump to a CVS snapshot, this should solve bad temperature offsets
+ on 2.6.2 kernels.
*lm-sensors-2.8.3 (01 Feb 2004)
diff --git a/sys-apps/lm-sensors/Manifest b/sys-apps/lm-sensors/Manifest
index 203c2b8b2cc9..76ccda0eac5a 100644
--- a/sys-apps/lm-sensors/Manifest
+++ b/sys-apps/lm-sensors/Manifest
@@ -1,4 +1,5 @@
-MD5 32dadfed3ba57590b5accd0d80d78bb6 ChangeLog 6185
+MD5 e969241d1dcb9480f3f17c8c5c9c61a4 lm-sensors-2.8.3.20040202.ebuild 4696
+MD5 09346ffe2da1724e5200205c1dd4a91a ChangeLog 6396
MD5 e4c90be0b8769f3616567470e3c89ade lm-sensors-2.6.5.ebuild 2030
MD5 28373b812640d00c88c1b25d8e27d1f4 lm-sensors-2.8.0.ebuild 3697
MD5 8b2dc6ba7619678e04264b30ece4245b lm-sensors-2.8.3.ebuild 4725
@@ -19,4 +20,5 @@ MD5 265c3ccaffdf984cbd371aec994b3162 files/lm-sensors-2.8.0-sensors-detect-gento
MD5 f0520fc5631209ae9278e18d9b464d8e files/no-isadump-ppc.patch 1193
MD5 72151bdd499b580ff965dd1a2e4216fb files/lm-sensors-2.8.2-sensors-detect-gentoo.diff 4973
MD5 d8c62d91275ce75f12c70d068db57a97 files/rc_lm_sensors 621
+MD5 f98a80a36ac25c60c26904957c593174 files/digest-lm-sensors-2.8.3.20040202 78
MD5 2217cbce56dd9da8bbe4188a24c9412f files/rc 2006
diff --git a/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.3.20040202 b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.3.20040202
new file mode 100644
index 000000000000..f8b430a61f66
--- /dev/null
+++ b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.3.20040202
@@ -0,0 +1 @@
+MD5 b29e4db0adce852220ff9aaa939cc928 lm_sensors-2.8.3.20040202.tar.bz2 566758
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.3.20040202.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.3.20040202.ebuild
new file mode 100644
index 000000000000..2fcc5c46f80d
--- /dev/null
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.3.20040202.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.3.20040202.ebuild,v 1.1 2004/02/03 23:34:00 plasmaroo Exp $
+
+inherit flag-o-matic
+
+MY_P=${PN/-/_}-${PV}
+S="${WORKDIR}/${MY_P}"
+MYI2C="${WORKDIR}/i2c-headers"
+
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://dev.gentoo.org/~plasmaroo/patches/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+SLOT="${KV}"
+
+KEYWORDS="~x86 ~amd64 -ppc -sparc"
+LICENSE="GPL-2"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${PN}-2.8.2-sensors-detect-gentoo.diff > /dev/null || die
+
+ # Get the right I2C includes without dropping the kernel includes
+ mkdir -p ${MYI2C}/linux
+ cp /usr/include/linux/i2c* ${MYI2C}/linux/
+}
+
+src_compile() {
+ echo
+ einfo "*****************************************************************"
+ einfo
+ einfo "This ebuild assumes your /usr/src/linux kernel is the one you"
+ einfo "used to build i2c-2.8.2."
+ einfo
+ einfo "For 2.5+ series kernels, use the support already in the kernel"
+ einfo "under 'Character devices' -> 'I2C support' and then merge this"
+ einfo "ebuild."
+ einfo
+ einfo "To cross-compile, 'export LINUX=\"/lib/modules/<version>/build\"'"
+ einfo "or symlink /usr/src/linux to another kernel."
+ einfo
+ einfo "*****************************************************************"
+ echo
+
+ UserModeOnly=false
+ if [ "$LINUX" != "" ]; then
+ einfo "Cross-compiling using:- $LINUX"
+ LINUX=`echo $LINUX | sed 's/build\//build/'`
+ KV=`cut -d\ -f3 ${LINUX}include/linux/version.h | grep \" | sed -e 's/"//' -e 's/"//'`
+ if [ "${KV}" == "" ]; then
+ die "Could not get kernel version; make sure ${LINUX}include/linux/version.h is there!"
+ fi
+ else
+ LINUX='/usr/src/linux'
+ check_KV || die "Cannot find kernel in /usr/src/linux!"
+ einfo "Using kernel in /usr/src/linux/:- ${KV}"
+ fi
+ if [ `echo ${KV} | grep 2\.[56]\.` ]; then
+ einfo "You are using a 2.5 / 2.6 series kernel; only building utilities..."
+ UserModeOnly=true
+ else
+ einfo "You are using a `echo ${KV} | cut -d. -f-2` series kernel; building everything..."
+ fi
+ if [ "${KV}" != "${SLOT}" ]; then
+ echo
+ ewarn "WARNING:- Specified and running kernels do not match!"
+ ewarn "WARNING:- This package will be slotted as ${SLOT}!"
+ fi
+
+ if [ ! -e ${MYI2C}/linux/i2c.h ]; then
+ cp $LINUX/include/linux/i2c* ${MYI2C}/linux || die "No I2C Includes! Install I2C!"
+ fi
+
+ echo; einfo "You may safely ignore any errors from compilation"
+ einfo "that contain 'No such file' references."
+
+ echo
+ filter-flags -fPIC -fstack-protector
+
+ cd ${S}
+ emake clean
+
+ if [ ${UserModeOnly} == true ]; then
+ emake CC=${CC} I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ else
+ emake CC=${CC} I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ fi
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/sbin
+ if [ ${UserModeOnly} == true ]; then
+ emake DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man user_install || die "Install failed!"
+ else
+ emake LINUX=$LINUX DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man install || die "Install failed!"
+ fi
+ cp ${D}/${D}* ${D} -Rf
+ rm ${D}/var -Rf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc lm_sensors
+ dodoc BACKGROUND BUGS CHANGES CONTRIBUTORS COPYING INSTALL QUICKSTART \
+ README* TODO
+ cp -a doc/* ${D}/usr/share/doc/${PF}
+
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+ echo
+}