summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-11 04:09:38 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-11 04:09:38 +0000
commit7b86f722a89e78aedd31fe0407ab9d907d503efe (patch)
treeaa39c3a63f8441917410851ea48728c70edcb7de /sys-apps/man
parent+dev-libs/libtomcrypt:libtommath +dev-libs/libtomcrypt:tomsfastmath (diff)
downloadhistorical-7b86f722a89e78aedd31fe0407ab9d907d503efe.tar.gz
historical-7b86f722a89e78aedd31fe0407ab9d907d503efe.tar.bz2
historical-7b86f722a89e78aedd31fe0407ab9d907d503efe.zip
Fix cross-compile support.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog6
-rw-r--r--sys-apps/man/Manifest13
-rw-r--r--sys-apps/man/files/man-1.6-cross-compile.patch61
-rw-r--r--sys-apps/man/man-1.6-r1.ebuild5
4 files changed, 77 insertions, 8 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 3918b87ee4d2..d966b2450c5c 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.72 2005/07/09 22:49:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.73 2005/08/11 04:09:38 vapier Exp $
+
+ 11 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6-cross-compile.patch, man-1.6-r1.ebuild:
+ Fix cross-compile support.
*man-1.6-r1 (09 Jul 2005)
diff --git a/sys-apps/man/Manifest b/sys-apps/man/Manifest
index 41982dcc3d64..7fcdb7018628 100644
--- a/sys-apps/man/Manifest
+++ b/sys-apps/man/Manifest
@@ -2,14 +2,15 @@
Hash: SHA1
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 6c53a64b952ae7bf8cf5ef63ed7e5537 man-1.6-r1.ebuild 2830
+MD5 47b98409df4110ade3e495249587f2b5 man-1.6-r1.ebuild 2909
MD5 9c896566b39c57595f9b9c807aa05a00 man-1.5p.ebuild 2574
MD5 630f1ea425178af59dd62c7c006dafaf man-1.6.ebuild 2685
-MD5 6c3ca5ade51eba7a215ee6ebd2de75a4 ChangeLog 10576
+MD5 81bf4e741f1a5dac8a99cc2b80d5fead ChangeLog 10713
MD5 90c01e3cfecc4bc92266780a9be71429 files/digest-man-1.6 59
MD5 80f2a25fb0b5692f39a1990527a93271 files/man-1.5m-groff-1.18.patch 923
MD5 90c01e3cfecc4bc92266780a9be71429 files/digest-man-1.6-r1 59
MD5 14e1c7533927dfb89900ee788666b342 files/man-1.5p-defmanpath-symlinks.patch 663
+MD5 331c925e304b56d63aa2c97dcc8e08fc files/man-1.6-cross-compile.patch 1744
MD5 6d6e219c5e8357b2d60e92e0ac88d76b files/digest-man-1.5p 60
MD5 148b7ee661e1e9384930fbd508dd5027 files/man-1.5p-parallel-make.patch 437
MD5 a1fe892ffb27e5e044ed342b611d2db1 files/makewhatis.cron 126
@@ -17,9 +18,9 @@ MD5 bc796c3f2d1f9becb3d0bedc1b6dc051 files/man-1.6-parallel-make.patch 1033
MD5 7b2b00aace5bcdb963286e235eaf22b2 files/man-1.5p-search-order.patch 519
MD5 ecb128fe6db790f05629a8b2eca4c4fa files/man-1.6-message-order.patch 833
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC0FSdgIKl8Uu19MoRAskmAJ4oMomkMLT7qenelZ4cuQlsGrw9tACeLGzx
-CiGO1y+RgEu21yg9Saz1aLg=
-=Mjiv
+iD8DBQFC+s+ogIKl8Uu19MoRAhXbAJwI4llJaqjjb60SBCjvjYFXkK4QPACggCPd
+F5ZpjKEZ599neqGopCvyIxs=
+=dJBY
-----END PGP SIGNATURE-----
diff --git a/sys-apps/man/files/man-1.6-cross-compile.patch b/sys-apps/man/files/man-1.6-cross-compile.patch
new file mode 100644
index 000000000000..184236918b91
--- /dev/null
+++ b/sys-apps/man/files/man-1.6-cross-compile.patch
@@ -0,0 +1,61 @@
+Fix up to work with cross-compiling ... most of these tests only
+need to see if the example compiled, not whether it runs ...
+
+--- configure
++++ configure
+@@ -232,15 +232,13 @@
+
+ echo checking for POSIX.1 header files
+ echo "#include <unistd.h>
+-main() {
+ #ifdef _POSIX_VERSION
+-exit(0);
++main() { exit(0); }
+ #else
+-exit(1);
+-#endif
+-}" > conftest.c
++# error no _POSIX_VERSION
++#endif" > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then
++if test -s conftest ; then
+ DEFS="$DEFS -DPOSIX"
+ fi
+ rm -f conftest conftest.c
+@@ -249,7 +247,7 @@
+ echo "#include <strings.h>
+ main() { exit(0); rindex(0, 0); bzero(0, 0); }" > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ else DEFS="$DEFS -DUSG"
+ fi
+ rm -f conftest conftest.c
+@@ -258,7 +256,7 @@
+ echo '#include <sys/types.h>
+ main() { uid_t x; exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ else
+ uid_t=`awk '/pw_uid;/ {print $1}' $INCLUDEDIR/pwd.h`
+ DEFS="$DEFS -Duid_t=${uid_t} -Dgid_t=${uid_t}"
+@@ -291,7 +289,7 @@
+ #endif
+ main() { char *p = (char *) alloca(1); exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then :
++if test -s conftest ; then :
+ elif test -d /usr/ucblib; then LIBS="$LIBS -L/usr/ucblib -lucb"
+ elif test -f /usr/lib/libPW.a; then LIBS="$LIBS -lPW"
+ else DEFS="$DEFS -DALLOCA_MISSING"
+@@ -321,7 +319,7 @@
+ struct option long_opts[] = { { "", no_argument, NULL, 0 } };
+ main() { exit(0); }' > conftest.c
+ eval $compile
+-if test -s conftest && ./conftest 2>/dev/null; then
++if test -s conftest ; then
+ manpathoption="--path"
+ else
+ manpathoption="-w"
diff --git a/sys-apps/man/man-1.6-r1.ebuild b/sys-apps/man/man-1.6-r1.ebuild
index 330aaadf5ad5..9db2e6e5ef93 100644
--- a/sys-apps/man/man-1.6-r1.ebuild
+++ b/sys-apps/man/man-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6-r1.ebuild,v 1.1 2005/07/09 22:49:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6-r1.ebuild,v 1.2 2005/08/11 04:09:38 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -25,6 +25,9 @@ src_unpack() {
# Make sure we can build with -j :)
epatch "${FILESDIR}"/man-1.6-parallel-make.patch
+ # We love to cross-compile
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+
# Fix message order in en lang file which triggers segv's for
# non-english users #97541
epatch "${FILESDIR}"/man-1.6-message-order.patch