summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-11 10:38:24 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-11 10:38:24 +0000
commitcd23165f10ecdea217d5e76bce73ea8b864fd9f4 (patch)
tree02c3db6d0016644d103ed10e99619b83022f462e /sys-apps/microcode-ctl
parentremoving unused diffs (diff)
downloadhistorical-cd23165f10ecdea217d5e76bce73ea8b864fd9f4.tar.gz
historical-cd23165f10ecdea217d5e76bce73ea8b864fd9f4.tar.bz2
historical-cd23165f10ecdea217d5e76bce73ea8b864fd9f4.zip
microcode_ctl moved to microcode-ctl
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog24
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.062
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild45
3 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
new file mode 100644
index 000000000000..2efb95b0b043
--- /dev/null
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for sys-apps/microcode-ctl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.1 2003/02/11 10:38:24 seemant Exp $
+
+*microcode_ctl-1.06 (30 Apr 2002)
+
+ 11 Feb 2003; Seemant Kulleen <seemant@gentoo.org>
+ microcode-ctl-1.06.ebuild :
+
+ Moved to sys-apps/microcode-ctl from sys-apps/microcode_ctl. And the
+ stuff in files/ is on a tarball on the mirrors instead.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
+ changed sparc ~sparc keywords
+
+ 21 Jul 2002; Mark Guertin <gerk@gentoo.org>:
+ updated keywords (-ppc -sparc -sparc64)
+
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> microcode_ctl-1.06.ebuild :
+ Added KEYWORDS, SLOT.
+
+ 30 Apr 2002; William McArthur <sandymac@gentoo.org> microcode_ctl-1.06.ebuild:
+
+ Initial add to portage.
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06
new file mode 100644
index 000000000000..0bdd3be6c236
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06
@@ -0,0 +1,2 @@
+MD5 4008903ba66e88e4eccca4256363cf30 microcode_ctl-1.06.tar.gz 126450
+MD5 5c8f0ebde75270dee22a2dc64fa76583 microcode-ctl-1.06-gentoo.tar.bz2 105952
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
new file mode 100644
index 000000000000..8071f7ed3b30
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild,v 1.1 2003/02/11 10:38:24 seemant Exp $
+
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2
+ http://cvs.gentoo.org/~seemant/${P}-gentoo.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 -ppc -sparc -hppa -mips -alpha"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ make all || die "compile problem"
+}
+
+src_install() {
+ into /usr/
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+ insinto /etc/
+ doins ${WORKDIR}/${PV}/microcode.dat
+ exeinto /etc/init.d/
+ doexe ${WORKDIR}/${PV}/microcode_ctl
+}
+
+pkg_postinst() {
+ einfo "Your kernel must include both devfs and microcode update support."
+ echo
+ einfo "To update the microcode now, run"
+ einfo ""
+ einfo "\tmicrocode_ctl -u"
+ einfo ""
+ einfo "The update will not survive a reboot. To have it do that run"
+ einfo ""
+ einfo "\trc-update add microcode_ctl default"
+}