summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-14 20:51:05 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-14 20:51:05 +0000
commit2f9eb62e83f29cf5eb3017b08635a3159f7e4292 (patch)
tree32c2a679a2764d5bb46142753f82cba86d6618a8 /sys-apps/openrc/openrc-9999.ebuild
parentSecurity bump, see bug #217232. Also fixes bug #217293. (diff)
downloadhistorical-2f9eb62e83f29cf5eb3017b08635a3159f7e4292.tar.gz
historical-2f9eb62e83f29cf5eb3017b08635a3159f7e4292.tar.bz2
historical-2f9eb62e83f29cf5eb3017b08635a3159f7e4292.zip
get rid of issue with 'net.*' literally appearing
Package-Manager: portage-2.1.5_rc3
Diffstat (limited to 'sys-apps/openrc/openrc-9999.ebuild')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 7321513e1bdf..602e8a65b620 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.25 2008/04/12 00:39:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.26 2008/04/14 20:51:05 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -156,7 +156,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in "${ROOT}"/etc/init.d/net.* ; do
+ for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."