summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-14 22:14:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-14 22:14:33 +0000
commit3da1ddc57408b40d0e8680bda9b9243769883511 (patch)
tree2ae60aefc22792113e3c4dd9536c41fa99fe8a4d /sys-apps/partimage
parentUpdated ebuild to use SF mirrors and cleaned it up some. Also moved to stable... (diff)
downloadhistorical-3da1ddc57408b40d0e8680bda9b9243769883511.tar.gz
historical-3da1ddc57408b40d0e8680bda9b9243769883511.tar.bz2
historical-3da1ddc57408b40d0e8680bda9b9243769883511.zip
Updated ebuild to use SF mirrors and cleaned it up some. Also moved to stable after some testing.
Diffstat (limited to 'sys-apps/partimage')
-rw-r--r--sys-apps/partimage/Manifest4
-rw-r--r--sys-apps/partimage/partimage-0.6.2.ebuild16
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-apps/partimage/Manifest b/sys-apps/partimage/Manifest
index cda1e9c0980c..2bc188863ee9 100644
--- a/sys-apps/partimage/Manifest
+++ b/sys-apps/partimage/Manifest
@@ -1,3 +1,3 @@
-MD5 eef636f9026169735d5e7527119c1580 partimage-0.6.2.ebuild 1438
-MD5 13fea62b94c1b9ab9f13e29fb48575b9 ChangeLog 830
+MD5 5b6b0adf50b6144283be542d5b9a7d6f partimage-0.6.2.ebuild 1410
+MD5 de340a577b37bc757d0199b0142df607 ChangeLog 1009
MD5 6fd04332b7f640a2aa71f208d2bd2dc8 files/digest-partimage-0.6.2 68
diff --git a/sys-apps/partimage/partimage-0.6.2.ebuild b/sys-apps/partimage/partimage-0.6.2.ebuild
index 28f4b7a46ad0..19363af47181 100644
--- a/sys-apps/partimage/partimage-0.6.2.ebuild
+++ b/sys-apps/partimage/partimage-0.6.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/partimage/partimage-0.6.2.ebuild,v 1.4 2003/02/13 16:08:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/partimage/partimage-0.6.2.ebuild,v 1.5 2003/05/14 22:14:30 robbat2 Exp $
DESCRIPTION="Console-based application to efficiently save raw partition data to an image file. Optional encryption/compression support."
HOMEPAGE="http://www.partimage.org/"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/partimage/${P}.tar.bz2"
+SRC_URI="mirror://sourceforge/partimage/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="ssl"
RDEPEND="virtual/glibc
@@ -15,6 +15,7 @@ RDEPEND="virtual/glibc
>=dev-libs/lzo-1.08
>=dev-libs/newt-0.50.35-r1
>=sys-libs/slang-1.4.5-r2
+ sys-apps/bzip2
ssl? ( >=dev-libs/openssl-0.9.6g )"
DEPEND="${RDEPEND} sys-devel/autoconf"
@@ -31,12 +32,9 @@ src_compile() {
# SSL is optional
local sslconf
use ssl || sslconf="--disable-ssl"
- ./configure \
+ econf \
${sslconf} \
- --prefix=/usr \
- --infodir=/usr/share/doc/${PF} \
- --sysconfdir=/etc \
- --mandir=/usr/share/man || die "./configure failed"
+ --infodir=/usr/share/doc/${PF}
cp Makefile Makefile.orig
sed -e "s/partimag\.root/root.root/g" Makefile.orig > Makefile
emake || die
@@ -48,5 +46,7 @@ src_install() {
sysconfdir=${D}/etc \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/doc/${PF} \
+ localedir=${D}/usr/share/locale \
+ gettextsrcdir=${D}/usr/share/gettext/po \
install || die
}