summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2006-06-16 19:43:14 +0000
committerStephen Klimaszewski <steev@gentoo.org>2006-06-16 19:43:14 +0000
commitd09d52b8b2f436ed1c37ad2a2ad82a3864d8d1d1 (patch)
tree0a2d1c433436bacdc9afd20ecf05fcb0e70e3383 /sys-apps/pmount/pmount-0.9.11.ebuild
parentRegen manifest. (diff)
downloadhistorical-d09d52b8b2f436ed1c37ad2a2ad82a3864d8d1d1.tar.gz
historical-d09d52b8b2f436ed1c37ad2a2ad82a3864d8d1d1.tar.bz2
historical-d09d52b8b2f436ed1c37ad2a2ad82a3864d8d1d1.zip
Version bump to 0.9.11. Closes Bug 136694. Thanks to Daniel Webert for the report
Package-Manager: portage-2.1
Diffstat (limited to 'sys-apps/pmount/pmount-0.9.11.ebuild')
-rw-r--r--sys-apps/pmount/pmount-0.9.11.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/pmount/pmount-0.9.11.ebuild b/sys-apps/pmount/pmount-0.9.11.ebuild
new file mode 100644
index 000000000000..dab2de2be6a1
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.11.ebuild,v 1.1 2006/06/16 19:43:14 steev Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://www.piware.de/projects.shtml"
+SRC_URI="http://www.piware.de/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt"
+
+DEPEND=">=sys-apps/dbus-0.33
+ >=sys-apps/hal-0.5.2
+ >=sys-fs/sysfsutils-1.3.0
+ crypt? ( sys-fs/cryptsetup-luks )"
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:/sbin/cryptsetup:/bin/cryptsetup:' -i src/policy.h
+ append-ldflags $(bindnow-flags)
+}
+
+src_install () {
+ # this is where we mount stuff
+ # moved to hal as of 0.5.7-r1
+ #keepdir /media
+
+ # Must be run SETUID
+ exeinto /usr/bin
+ exeopts -m 4710 -g plugdev
+ doexe src/pmount src/pumount src/pmount-hal
+
+ dodoc AUTHORS ChangeLog TODO
+ doman man/pmount.1 man/pumount.1 man/pmount-hal.1
+
+ insinto /etc
+ doins etc/pmount.allow
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package has been installed setuid. The permissions are as such that"
+ einfo "only users that belong to the plugdev group are allowed to run this."
+ einfo
+ einfo "Please add your user to the plugdev group to be able to mount USB drives"
+}