summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2003-02-08 04:33:15 +0000
committerJon Nall <nall@gentoo.org>2003-02-08 04:33:15 +0000
commitc1b6b377e6ffea4f4388aa00698f941799deec05 (patch)
treed9320ed46eed96577344ecdbc98a1f1d5c63dc69 /sys-apps/quik
parentAdded patch to undefine resolve_symlinks to make df output readable (diff)
downloadhistorical-c1b6b377e6ffea4f4388aa00698f941799deec05.tar.gz
historical-c1b6b377e6ffea4f4388aa00698f941799deec05.tar.bz2
historical-c1b6b377e6ffea4f4388aa00698f941799deec05.zip
bug fix for missing fclose()
Diffstat (limited to 'sys-apps/quik')
-rw-r--r--sys-apps/quik/ChangeLog7
-rw-r--r--sys-apps/quik/files/digest-quik-2.0.1.0-r32
-rw-r--r--sys-apps/quik/files/quik-2.0.1.0-fclose-bug.patch10
-rw-r--r--sys-apps/quik/quik-2.0.1.0-r3.ebuild63
4 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/quik/ChangeLog b/sys-apps/quik/ChangeLog
index 6a1b48f1a92c..ceef19ab400f 100644
--- a/sys-apps/quik/ChangeLog
+++ b/sys-apps/quik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/quik
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/quik/ChangeLog,v 1.6 2003/01/28 14:20:45 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quik/ChangeLog,v 1.7 2003/02/08 04:33:15 nall Exp $
+
+*quik-2.0.1.0-r3 (04 Feb 2003)
+
+ 04 Feb 2003; Jon Nall <nall@gentoo.org> files/quik-2.0.1.0-fclose-bug.patch :
+ fixed patch to avoid SIGSEGV. this closes bug #14817
*quik-2.0.1.0-r2 (28 Jan 2003)
diff --git a/sys-apps/quik/files/digest-quik-2.0.1.0-r3 b/sys-apps/quik/files/digest-quik-2.0.1.0-r3
new file mode 100644
index 000000000000..1aa7f3e72997
--- /dev/null
+++ b/sys-apps/quik/files/digest-quik-2.0.1.0-r3
@@ -0,0 +1,2 @@
+MD5 d546fd92dfa16255e062fa8505a5b8d4 quik_2.0e.orig.tar.gz 39440
+MD5 71828c98994bf3a3f7d08bc0672e33e5 quik_2.0e-1.diff.gz 7694
diff --git a/sys-apps/quik/files/quik-2.0.1.0-fclose-bug.patch b/sys-apps/quik/files/quik-2.0.1.0-fclose-bug.patch
new file mode 100644
index 000000000000..9d43025cf89c
--- /dev/null
+++ b/sys-apps/quik/files/quik-2.0.1.0-fclose-bug.patch
@@ -0,0 +1,10 @@
+--- quik/quik.c.orig 2003-02-04 23:40:21.000000000 -0600
++++ quik/quik.c 2003-02-04 23:40:39.000000000 -0600
+@@ -454,6 +454,7 @@
+ exit(0);
+ }
+ }
++ fclose(f);
+ }
+
+ config_file = NULL;
diff --git a/sys-apps/quik/quik-2.0.1.0-r3.ebuild b/sys-apps/quik/quik-2.0.1.0-r3.ebuild
new file mode 100644
index 000000000000..3dc3622a2918
--- /dev/null
+++ b/sys-apps/quik/quik-2.0.1.0-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/quik/quik-2.0.1.0-r3.ebuild,v 1.1 2003/02/08 04:33:15 nall Exp $
+
+inherit mount-boot
+
+S="${WORKDIR}/quik-2.0"
+HOMEPAGE=""
+DESCRIPTION="OldWorld PowerMac Bootloader"
+MY_P="quik_2.0e.orig.tar.gz"
+DEB_P="quik_2.0e-1.diff"
+DEB_URI="ftp://ftp.debian.org/debian/pool/main/q/quik"
+SRC_URI="${DEB_URI}/${MY_P} ${DEB_URI}/${DEB_P}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc -x86 -alpha -sparc"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${MY_P} || die
+ zcat ${DISTDIR}/${DEB_P}.gz | patch -p1 -d ${S}|| die
+ [ -z "${CC}" ] && CC=gcc
+ GCC_VERSION="`${CC} -dumpversion | cut -d. -f1,2,3`"
+ einfo "GCC_VERSION: ${GCC_VERSION}"
+ cd ${S}/quik
+ # this patch fixes bug #14817
+ einfo "Fixing missing fclose()"
+ patch -p1 < ${FILESDIR}/quik-2.0.1.0-fclose-bug.patch || die "patch failed"
+ if [ "${GCC_VERSION}" != "2.95" ] ; then
+ cd ${S}/second
+ patch -p1 < ${FILESDIR}/quik-2.0.1.0-gcc-321.patch || die "patch failed"
+ cp Makefile Makefile.orig
+ sed -e s:'$(LD) $(LDFLAGS) -Bstatic -o second $(OBJS) -lext2fs':'$(LD) $(LDFLAGS) -Bstatic -o second $(OBJS) -lext2fs -lc -lgcc -L/usr/lib/gcc-lib/powerpc-unknown-linux-gnu/'${GCC_VERSION}/: Makefile.orig > Makefile
+
+ fi
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ #i'll have a look at this later
+ install -d -m 755 ${D}/sbin || die
+ install -d -m 755 ${D}/etc || die
+ install -d -m 755 ${D}/boot || die
+ install -d -m 755 ${D}/usr/share/man/man5 || die
+ install -d -m 755 ${D}/usr/share/man/man8 || die
+ install -s -m 755 quik/quik ${D}/sbin || DIE
+ install -m 644 man/quik.conf.5 \
+ ${D}/usr/share/man/man5 || DIE
+ install -m 644 man/quik.8 man/bootstrap.8 \
+ ${D}/usr/share/man/man8 || DIE
+
+ install -m 444 first/first.b second/second.b \
+ second/second ${D}/boot || die
+ install -m 644 etc/quik.conf ${D}/etc || die
+}