summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:35 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:14:35 +0000
commit65ff9109d975303a292ac9e7acd38261c91079cc (patch)
tree984b1519ba60a35ae6d27439329dcf5b4f984668 /sys-apps/sh-utils
parentPrepared for rc3 (diff)
downloadhistorical-65ff9109d975303a292ac9e7acd38261c91079cc.tar.gz
historical-65ff9109d975303a292ac9e7acd38261c91079cc.tar.bz2
historical-65ff9109d975303a292ac9e7acd38261c91079cc.zip
Prepared for rc3
Diffstat (limited to 'sys-apps/sh-utils')
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild
index 94268ad55891..8ed242e12111 100644
--- a/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild
+++ b/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild
@@ -2,13 +2,16 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild,v 1.5 2000/11/12 21:35:07 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r1.ebuild,v 1.6 2000/11/30 23:14:34 achim Exp $
P=sh-utils-2.0j
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Your standard GNU shell utilities"
SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+DEPEND=">=sys-libs/glibc-2.1.3"
+RDEPEND="$DEPEND
+ >=sys-apps/bash-2.04"
src_unpack() {
unpack ${A}
@@ -20,23 +23,15 @@ src_unpack() {
src_compile() {
export CFLAGS="${CFLAGS}"
try ./configure --host=${CHOST} --build=${CHOST} --prefix=/usr \
- --with-catgets --without-included-regex
- try make
+ --without-included-regex
+ try make ${MAKEOPTS}
}
-src_install() {
- cd ${S}/src
- into /
- dobin echo hostname pwd true uname id stty date true false sleep su
- chmod u+s ${D}/bin/su
- into /usr
- dobin basename chroot dirname env expr factor groups id logname nice nohup pathchk printenv printf seq tee test tty users who whoami yes
- cd ${S}
- doinfo doc/sh-utils.info
- doman man/*.1
- MOPREFIX=sh-utils
- domo po/*.po
- dodoc ABOUT-NLS AUTHORS COPYING ChangeLog ChangeLog.0 NEWS README THANKS TODO
+src_install() {
+ try make prefix=${D}/usr install
+ rm -rf ${D}/usr/lib
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
+ NEWS README THANKS TODO
}