summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-07-25 12:02:21 +0000
committerNed Ludd <solar@gentoo.org>2005-07-25 12:02:21 +0000
commit36526b302d7c8b6e2a714b34eaff5c353db8b656 (patch)
tree2a7de598af1a277a74e9f88682525a1b9a8b871c /sys-apps/shadow/files
parentAdded to ~ppc (diff)
downloadhistorical-36526b302d7c8b6e2a714b34eaff5c353db8b656.tar.gz
historical-36526b302d7c8b6e2a714b34eaff5c353db8b656.tar.bz2
historical-36526b302d7c8b6e2a714b34eaff5c353db8b656.zip
- added no /usr/bin suid option as local use flag nousuid for single user systems
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-apps/shadow/files')
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.7-r41
-rw-r--r--sys-apps/shadow/files/shadow-4.0.7-perms.patch49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.7-r4 b/sys-apps/shadow/files/digest-shadow-4.0.7-r4
new file mode 100644
index 000000000000..57cfe54be85e
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.7-r4
@@ -0,0 +1 @@
+MD5 89ebec0d1c0d861a5bd5c4c63e5cb0cc shadow-4.0.7.tar.bz2 1019749
diff --git a/sys-apps/shadow/files/shadow-4.0.7-perms.patch b/sys-apps/shadow/files/shadow-4.0.7-perms.patch
new file mode 100644
index 000000000000..f754ca3f3b14
--- /dev/null
+++ b/sys-apps/shadow/files/shadow-4.0.7-perms.patch
@@ -0,0 +1,49 @@
+diff -Nrup src/Makefile.am src/Makefile.am
+--- src/Makefile.am 2005-07-24 12:33:11.000000000 -0400
++++ src/Makefile.am 2005-07-24 14:45:52.000000000 -0400
+@@ -46,6 +46,8 @@ noinst_PROGRAMS = id sulogin
+
+ suidbins = su
+ suidubins = chage chfn chsh expiry gpasswd newgrp passwd
++suidbinperms = 4711
++suidubinperms = 4711
+
+ LDADD = $(top_builddir)/libmisc/libmisc.a \
+ $(top_builddir)/lib/libshadow.la
+@@ -71,8 +73,8 @@ install-am: all-am
+ ln -sf newgrp $(DESTDIR)$(ubindir)/sg
+ ln -sf vipw $(DESTDIR)$(usbindir)/vigr
+ for i in $(suidbins); do \
+- chmod -f 4755 $(DESTDIR)$(bindir)/$$i; \
++ chmod -f $(suidbinperms) $(DESTDIR)$(bindir)/$$i; \
+ done
+ for i in $(suidubins); do \
+- chmod -f 4755 $(DESTDIR)$(ubindir)/$$i; \
++ chmod -f $(suidubinperms) $(DESTDIR)$(ubindir)/$$i; \
+ done
+diff -Nrup src/Makefile.in src/Makefile.in
+--- src/Makefile.in 2005-07-24 12:33:56.000000000 -0400
++++ src/Makefile.in 2005-07-24 14:46:07.000000000 -0400
+@@ -352,6 +352,9 @@ INCLUDES = \
+ # id and groups are from gnu, sulogin from sysvinit
+ suidbins = su
+ suidubins = chage chfn chsh expiry gpasswd newgrp passwd
++suidbinperms = 4711
++suidubinperms = 4711
++
+ LDADD = $(top_builddir)/libmisc/libmisc.a \
+ $(top_builddir)/lib/libshadow.la
+
+@@ -835,10 +838,10 @@ install-am: all-am
+ ln -sf newgrp $(DESTDIR)$(ubindir)/sg
+ ln -sf vipw $(DESTDIR)$(usbindir)/vigr
+ for i in $(suidbins); do \
+- chmod -f 4755 $(DESTDIR)$(bindir)/$$i; \
++ chmod -f $(suidbinperms) $(DESTDIR)$(bindir)/$$i; \
+ done
+ for i in $(suidubins); do \
+- chmod -f 4755 $(DESTDIR)$(ubindir)/$$i; \
++ chmod -f $(suidubinperms) $(DESTDIR)$(ubindir)/$$i; \
+ done
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.