summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Blaabjerg <styx@gentoo.org>2002-12-12 12:43:01 +0000
committerJoachim Blaabjerg <styx@gentoo.org>2002-12-12 12:43:01 +0000
commit0eef9b8bba5ab539345596b6354ba19bcec40743 (patch)
tree30949c4f3baf2d30dac8af8ef15d658f85119318 /sys-apps
parentDamn, I glad I masked the new revision... Forgot to commit the rc script :P (diff)
downloadhistorical-0eef9b8bba5ab539345596b6354ba19bcec40743.tar.gz
historical-0eef9b8bba5ab539345596b6354ba19bcec40743.tar.bz2
historical-0eef9b8bba5ab539345596b6354ba19bcec40743.zip
Re-adding ACL support, fixes bug #11936
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fileutils/ChangeLog11
-rw-r--r--sys-apps/fileutils/files/digest-fileutils-4.1.11-r12
-rw-r--r--sys-apps/fileutils/fileutils-4.1.11-r1.ebuild77
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-apps/fileutils/ChangeLog b/sys-apps/fileutils/ChangeLog
index f0fc99921230..39860a08af38 100644
--- a/sys-apps/fileutils/ChangeLog
+++ b/sys-apps/fileutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/fileutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.8 2002/12/09 04:37:24 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/ChangeLog,v 1.9 2002/12/12 12:43:01 styx Exp $
+
+*fileutils-4.1.11-r1 (12 Dec 2002)
+
+ 12 Dec 2002; Joachim Blaabjerg <styx@gentoo.org> fileutils-4.1.11-r1.ebuild,
+ files/digest-fileutils-4.1.11-r1, ChangeLog :
+
+ Readded the ACL support, ditched xdelta (what's the point of using that
+ anyway?) and forward-ported the 4.1.8 patch to 4.1.11, masked for testing.
+ Fixes bug #11936
\* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
diff --git a/sys-apps/fileutils/files/digest-fileutils-4.1.11-r1 b/sys-apps/fileutils/files/digest-fileutils-4.1.11-r1
new file mode 100644
index 000000000000..5b5b3916a020
--- /dev/null
+++ b/sys-apps/fileutils/files/digest-fileutils-4.1.11-r1
@@ -0,0 +1,2 @@
+MD5 bb4c7625c96a4123d3dddde1a2cbcfa1 fileutils-4.1.11.tar.gz 2563888
+MD5 9adef12e6166bba1732b2f0c433c79ac fileutils-4.1.11acl-0.8.25.diff.gz 10788
diff --git a/sys-apps/fileutils/fileutils-4.1.11-r1.ebuild b/sys-apps/fileutils/fileutils-4.1.11-r1.ebuild
new file mode 100644
index 000000000000..8bc9b2073a6f
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.1.11-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.1.11-r1.ebuild,v 1.1 2002/12/12 12:43:01 styx Exp $
+
+IUSE="acl nls build"
+ACLPV=4.1.11acl-0.8.25
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${P}.tar.gz http://cvs.gentoo.org/~styx/fileutils-${ACLPV}.diff.gz"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`use acl`" ]; then
+ zcat ${DISTDIR}/fileutils-${ACLPV}.diff | patch -p0
+ cd ${S}/lib
+ cat ${FILESDIR}/acl.c.diff | patch -p0 -l || die
+ fi
+
+ cd ${S}
+ # Fix braindead scripting problem in configure
+ # <azarah@gentoo.org> (25 Sep 2002)
+ patch -p1 < ${FILESDIR}/${P}-configure.patch || die
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --bindir=/bin \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ bindir=${D}/bin \
+ install || die
+
+ cd ${D}
+ dodir /usr/bin
+ rm -rf usr/lib
+ cd usr/bin
+ ln -s ../../bin/* .
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
+
+ #conflicts with textutils. seems that they install the same
+ #.info file between the two of them
+ rm -f ${D}/usr/share/info/coreutils.info
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+