summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-02-26 20:18:54 +0000
committerMark Guertin <gerk@gentoo.org>2003-02-26 20:18:54 +0000
commit2977da84237826314c7f57de384585429c29a04b (patch)
treec3e1df255a291b927af3954d57e16b1396178f56 /sys-apps
parentadd new version of ccache (diff)
downloadhistorical-2977da84237826314c7f57de384585429c29a04b.tar.gz
historical-2977da84237826314c7f57de384585429c29a04b.tar.bz2
historical-2977da84237826314c7f57de384585429c29a04b.zip
new upstream version, important fixups
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/yaboot/ChangeLog8
-rw-r--r--sys-apps/yaboot/files/digest-yaboot-1.3.101
-rw-r--r--sys-apps/yaboot/files/yabootconfig-1.3.10.patch78
-rw-r--r--sys-apps/yaboot/yaboot-1.3.10.ebuild35
4 files changed, 121 insertions, 1 deletions
diff --git a/sys-apps/yaboot/ChangeLog b/sys-apps/yaboot/ChangeLog
index b9a0b8371976..f29f9d97149d 100644
--- a/sys-apps/yaboot/ChangeLog
+++ b/sys-apps/yaboot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/yaboot
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/ChangeLog,v 1.12 2003/02/12 21:44:01 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/ChangeLog,v 1.13 2003/02/26 20:18:54 gerk Exp $
+
+*yaboot-1.3.10 (26 Feb 2003)
+
+ 26 Feb 2003; Mark Guertin <gerk@gentoo.org> yaboot-1.3.10.ebuild files/digest-yaboot-1.3.10 files/yabootconfig-1.3.10.patch :
+ New yaboot version, fixes up ofpath issues upstream, also has support for
+ latest powermac machines. Important fixes, set as ppc
*yaboot-1.3.9.ebuild (Feb 12 2003)
diff --git a/sys-apps/yaboot/files/digest-yaboot-1.3.10 b/sys-apps/yaboot/files/digest-yaboot-1.3.10
new file mode 100644
index 000000000000..89c08fc0aa93
--- /dev/null
+++ b/sys-apps/yaboot/files/digest-yaboot-1.3.10
@@ -0,0 +1 @@
+MD5 9770dc5128b2aa45d16d2002a9565002 yaboot-1.3.10.tar.gz 273454
diff --git a/sys-apps/yaboot/files/yabootconfig-1.3.10.patch b/sys-apps/yaboot/files/yabootconfig-1.3.10.patch
new file mode 100644
index 000000000000..c9de2c10782f
--- /dev/null
+++ b/sys-apps/yaboot/files/yabootconfig-1.3.10.patch
@@ -0,0 +1,78 @@
+--- ybin/yabootconfig.orig 2003-02-08 23:53:46.000000000 -0500
++++ ybin/yabootconfig 2003-02-26 15:07:50.000000000 -0500
+@@ -4,6 +4,7 @@
+ ##
+ ## yabootconfig generates a simple /etc/yaboot.conf
+ ## Copyright (C) 2001, 2002, 2003 Ethan Benson
++## Patched for Gentoo and dual boot - Mark Guertin <gerk@gentoo.org>
+ ##
+ ## This program is free software; you can redistribute it and/or
+ ## modify it under the terms of the GNU General Public License
+@@ -264,6 +265,31 @@
+ return 0
+ }
+
++dualboot()
++{
++ DRIVELIST=`ls -d /dev/?d?* | grep "[sh]d[abcdefghijkl]" | cut -b 6-8 | sort -u`
++
++ for i in $DRIVELIST
++ do
++ HFS=`mac-fdisk -l "/dev/$i" | grep '\<Apple_HFS\>' | grep -v "CDROM" | cut -d" " -f1`
++ for h in $HFS
++ do
++ if [ !-x `hpmount -r $h` > /dev/null 2>&1 ] ; then
++ if [ `hpls mach_kernel 2>/dev/null` ] ; then
++ [ "$QUIET" = 0 ] && echo "Found possible OS X/Darwin partition at $h"
++ OSX=$h
++ fi
++ if [ "`hpls "System Folder" 2>/dev/null`" ] ; then
++ [ "$QUIET" = 0 ] && echo "Found possible Mac OS partition at $h"
++ MACOS=$h
++ fi
++ hpumount $h > /dev/null 2>&1
++ fi
++ done
++ done
++}
++
++
+ ##########
+ ## Main ##
+ ##########
+@@ -579,6 +605,15 @@
+ fi
+ fi
+
++## setup any Mac OS/OS X partitions
++dualboot
++if [ -n "$MACOS" ] ; then
++ MACOSBOOT="macos=${MACOS}\n"
++fi
++if [ -n "OSX" ] ; then
++ OSXBOOT="macosx=${OSX}\n"
++fi
++
+ ## generate global section of yaboot.conf
+ GLOBAL="## yaboot.conf generated by $PRG $VERSION
+ ##
+@@ -596,7 +631,7 @@
+ IMAGES="
+ image=$IMAGE
+ \tlabel=Linux
+-\tread-only\n${APPEND:-}"
++\tread-only\n${APPEND:-}\n${OSXBOOT:-}\n${MACOSBOOT:-}"
+
+ ## safely create a tmp file then move it into place after we are sure
+ ## it was written.
+@@ -667,4 +702,10 @@
+ fi
+ fi
+
++## Give user a warning about possible b0rkage
++
++[ "$QUIET" = 0 ] && echo -e "\nConfiguration complete. If there are no errors above you should
++have a working configuration. see man yaboot.conf if you run into
++any errors."
++
+ exit 0
diff --git a/sys-apps/yaboot/yaboot-1.3.10.ebuild b/sys-apps/yaboot/yaboot-1.3.10.ebuild
new file mode 100644
index 000000000000..f9e141b3b67a
--- /dev/null
+++ b/sys-apps/yaboot/yaboot-1.3.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/yaboot/yaboot-1.3.10.ebuild,v 1.1 2003/02/26 20:18:54 gerk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PPC Bootloader"
+SRC_URI="http://penguinppc.org/projects/yaboot/${P}.tar.gz"
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc -x86 -sparc -alpha"
+
+DEPEND="sys-apps/powerpc-utils
+ sys-apps/hfsutils
+ sys-apps/hfsplusutils"
+
+PROVIDE="virtual/bootloader"
+
+MAKEOPTS='PREFIX=/usr MANDIR=share/man'
+
+src_compile() {
+ export -n CFLAGS
+ export -n CXXFLAGS
+ # dual boot patch
+ patch -p0 < ${FILESDIR}/yabootconfig-${PV}.patch || die "patch failed"
+ emake ${MAKEOPTS} || die
+}
+
+src_install() {
+ cp etc/yaboot.conf etc/yaboot.conf.bak
+ sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
+ mv -f etc/yaboot.conf.edit etc/yaboot.conf
+ make ROOT=${D} ${MAKEOPTS} install || die
+}