summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-16 22:26:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-16 22:26:04 +0000
commitf2b6c68cd19bfe6c0173924676493cb540a19583 (patch)
treecf9fe7f5c8a408be331f38a2f5c52e46c399f2fb /sys-apps
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-f2b6c68cd19bfe6c0173924676493cb540a19583.tar.gz
historical-f2b6c68cd19bfe6c0173924676493cb540a19583.tar.bz2
historical-f2b6c68cd19bfe6c0173924676493cb540a19583.zip
fix cross-compiling logic #92694
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/Manifest2
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1-r6.ebuild13
2 files changed, 4 insertions, 11 deletions
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 140ed254165a..686e099ca239 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -3,7 +3,7 @@ MD5 0a532171a448adf8d523ca631e388f3b coreutils-5.2.1-r2.ebuild 4383
MD5 a041d2d2ace692ab73aa932cae01debf coreutils-5.2.1-r3.ebuild 4205
MD5 814ab16ac6cac4e2825942dad9b41e69 coreutils-5.2.1-r4.ebuild 4453
MD5 7ddbb3bd0c85181c0bc342e7dc41e239 coreutils-5.2.1-r5.ebuild 4619
-MD5 1ec944599c021653cd61bb244d01a2d0 coreutils-5.2.1-r6.ebuild 4462
+MD5 2363cef984f499e4dd5945b23b949c5f coreutils-5.2.1-r6.ebuild 4303
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 c63fee729a210ba400b1fb34bbbe76c5 files/DIR_COLORS 4053
MD5 a7f49f56e12b6b16a5c347a666fb9b37 files/digest-coreutils-5.2.1-r6 149
diff --git a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
index cedd84deecdb..fdbf14d65914 100644
--- a/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.3 2005/04/12 03:53:24 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1-r6.ebuild,v 1.4 2005/05/16 22:26:04 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
PATCH_VER=0.11
PATCHDIR="${WORKDIR}/patch"
@@ -66,14 +66,7 @@ src_unpack() {
# try to re-build the manpages by running `./bin --help`.
# When cross-compiling, we can't do that since 'bin' isn't
# a native binary, so let's just install outdated man-pages.
- [[ ${CTARGET:-${CHOST}} != ${CHOST} ]] && touch man/*.1
-
- # Rebuild of manpage seq.1 fails with ppc64 hardened so
- # We'll install the outdated copy.
- if use ppc64 && use hardened; then
- touch man/seq.1
- fi
-
+ tc-is-cross-compiler && touch man/*.1
}
src_compile() {