summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-27 10:33:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-27 10:33:26 +0000
commit7d144d4214e4af454eeac0dd99ed974a2d7bd2f0 (patch)
treeb21feb03d8b680ec75adedbc2db08218aa21eeca /sys-auth
parentAdd tun module detection/load to init script (diff)
downloadhistorical-7d144d4214e4af454eeac0dd99ed974a2d7bd2f0.tar.gz
historical-7d144d4214e4af454eeac0dd99ed974a2d7bd2f0.tar.bz2
historical-7d144d4214e4af454eeac0dd99ed974a2d7bd2f0.zip
old
Package-Manager: portage-2.2_pre2
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/bioapi/bioapi-1.2.2.ebuild94
-rw-r--r--sys-auth/bioapi/files/51-bioapi.rules2
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.2_patch58
-rw-r--r--sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch28
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild39
5 files changed, 0 insertions, 221 deletions
diff --git a/sys-auth/bioapi/bioapi-1.2.2.ebuild b/sys-auth/bioapi/bioapi-1.2.2.ebuild
deleted file mode 100644
index 54afc1769ea5..000000000000
--- a/sys-auth/bioapi/bioapi-1.2.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/bioapi-1.2.2.ebuild,v 1.4 2007/04/09 16:14:59 wolf31o2 Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Framework for biometric-based authentication"
-HOMEPAGE="http://www.bioapi.org"
-SRC_URI="http://www.qrivy.net/~michael/blua/${PN}/${P}.tar.bz2"
-LICENSE="bioapi"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt3"
-
-RDEPEND="qt3? ( =x11-libs/qt-3* )"
-
-src_compile() {
- VERGCC=$(gcc-version)
- if [ ${VERGCC} == 4.1 ]; then
- epatch ${FILESDIR}/bioapi-1.2.2_patch
- fi
- myconf="
- --host=${CHOST}\
- --prefix=/opt/bioapi \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libdir=/usr/$(get_libdir) \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man"
-
- if use qt3; then
- myconf="${myconf} --with-Qt-dir=/usr/qt/3"
- else
- myconf="${myconf} --without-Qt-dir"
- fi
-
- econf $myconf || die "./configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- #and now we have to handle the docs
- dodoc README\
- 00_License.htm \
- 01_Readme.htm \
- 09_Manifest.htm \
- 10_Build.htm \
- 11_Install.htm \
- 12_Use.htm \
- 20_Todo.htm \
- 30_History.htm \
- 31_Contributors.htm \
- 32_Contacts.htm \
- Disclaimer
- insinto /opt/bioapi/include
- doins include/bioapi_util.h include/installdefs.h \
- imports/cdsa/v2_0/inc/cssmtype.h
- doenvd ${FILESDIR}/20bioapi
- insinto /etc/udev/rules.d
- doins ${FILESDIR}/51-bioapi.rules
-}
-
-pkg_postinst() {
- einfo "Running Module Directory Services (MDS) ..."
- /opt/bioapi/bin/mds_install -s /usr/lib || die " MDS failure"
- /opt/bioapi/bin/mod_install -fi /usr/lib/libbioapi100.so || die " mds bioapi100 failed"
- /opt/bioapi/bin/mod_install -fi /usr/lib/libbioapi_dummy100.so || die " mds bioapi_dummy100 failed"
- /opt/bioapi/bin/mod_install -fi /usr/lib/libpwbsp.so || die " mds pwbsp failed"
-
- if use qt3; then
- /opt/bioapi/bin/mod_install -fi /usr/lib/libqtpwbsp.so || die " mds qtpwbsp failed"
- fi
-
- enewgroup bioapi
- chgrp bioapi /var/bioapi -R
- chmod g+w,o= /var/bioapi -R
- einfo "Note: users using bioapi must be in group bioapi."
-}
-
-pkg_prerm() {
- einfo "Running Module Directory Services (MDS) ..."
- /opt/bioapi/bin/mod_install -fu libbioapi100.so
- /opt/bioapi/bin/mod_install -fu libbioapi_dummy100.so
- /opt/bioapi/bin/mod_install -fu libpwbsp.so
-
- if use qt3; then
- /opt/bioapi/bin/mod_install -fu libqtpwbsp.so
- fi
-
- einfo "You might want to remove the group bioapi."
- einfo "You might want to remove /var/bioapi."
-}
diff --git a/sys-auth/bioapi/files/51-bioapi.rules b/sys-auth/bioapi/files/51-bioapi.rules
deleted file mode 100644
index 81319516ba7f..000000000000
--- a/sys-auth/bioapi/files/51-bioapi.rules
+++ /dev/null
@@ -1,2 +0,0 @@
-#Permissions for the Biometrics
-SUBSYSTEM=="usb_device", MODE="0660", GROUP="usb"
diff --git a/sys-auth/bioapi/files/bioapi-1.2.2_patch b/sys-auth/bioapi/files/bioapi-1.2.2_patch
deleted file mode 100644
index ee5202f4a138..000000000000
--- a/sys-auth/bioapi/files/bioapi-1.2.2_patch
+++ /dev/null
@@ -1,58 +0,0 @@
-diff -Nur bioapi-1.2.2-orig/addins/dl/mds/dal_classes.h bioapi-1.2.2/addins/dl/mds/dal_classes.h
---- bioapi-1.2.2-orig/addins/dl/mds/dal_classes.h 2005-06-10 02:35:44.000000000 +0200
-+++ bioapi-1.2.2/addins/dl/mds/dal_classes.h 2006-06-29 18:15:29.669647000 +0200
-@@ -455,9 +455,9 @@
- DAL_DATABASE_INFO_REF_PTR &prefDatabase,
- PORT_MUTEX_HANDLE &Mutex);
-
-- CSSM_RETURN DAL_DATABASE_INFO_LIST::GetDBNamesAndParameters(
-- CSSM_DL_DB_HANDLE DLDBHandle,
-- DAL_DB_OPEN_PARAM_PTR pParam);
-+ CSSM_RETURN GetDBNamesAndParameters(
-+ CSSM_DL_DB_HANDLE DLDBHandle,
-+ DAL_DB_OPEN_PARAM_PTR pParam);
- };
-
- #endif
-diff -Nur bioapi-1.2.2-orig/apps/Cmds/CdsaRec.cpp bioapi-1.2.2/apps/Cmds/CdsaRec.cpp
---- bioapi-1.2.2-orig/apps/Cmds/CdsaRec.cpp 2005-06-08 02:51:04.000000000 +0200
-+++ bioapi-1.2.2/apps/Cmds/CdsaRec.cpp 2006-06-29 18:14:14.889647000 +0200
-@@ -10,7 +10,7 @@
- #endif
- //////////////////////////////////////////////////////////////////////
-
--void QCdsaRecType< CCssmRecInfoType >::SpecifyAttributes()
-+template <> void QCdsaRecType< CCssmRecInfoType >::SpecifyAttributes()
- {
- m_outputAttributeData[CCssmRecInfoType::IDX_MODULEID].Info = s_BioApiAttrInfo_ModuleId;
- m_outputAttributeData[CCssmRecInfoType::IDX_MODULENAME].Info = s_BioApiAttrInfo_ModuleName;
-@@ -20,7 +20,7 @@
- m_outputAttributeData[CCssmRecInfoType::IDX_DESC].Info = s_BioApiAttrInfo_Description;
- }
-
--void QCdsaRecType< CEmmRecInfoType >::SpecifyAttributes()
-+template <> void QCdsaRecType< CEmmRecInfoType >::SpecifyAttributes()
- {
- m_outputAttributeData[CEmmRecInfoType::IDX_MODULEID].Info = s_BioApiAttrInfo_ModuleId;
- m_outputAttributeData[CEmmRecInfoType::IDX_DEVICEID].Info = s_BioApiAttrInfo_DeviceId;
-@@ -47,7 +47,7 @@
-
-
-
--void QCdsaRecType< CBioAPI_DeviceInfoType >::SpecifyAttributes()
-+template <> void QCdsaRecType< CBioAPI_DeviceInfoType >::SpecifyAttributes()
- {
- m_outputAttributeData[CBioAPI_DeviceInfoType::IDX_MODULE_ID].Info = s_BioApiAttrInfo_ModuleId;
- m_outputAttributeData[CBioAPI_DeviceInfoType::IDX_DEVICE_ID].Info = s_BioApiAttrInfo_DeviceId;
-diff -Nur bioapi-1.2.2-orig/apps/Cmds/QDirectory.h bioapi-1.2.2/apps/Cmds/QDirectory.h
---- bioapi-1.2.2-orig/apps/Cmds/QDirectory.h 2005-06-13 08:22:00.000000000 +0200
-+++ bioapi-1.2.2/apps/Cmds/QDirectory.h 2006-06-29 18:14:14.889647000 +0200
-@@ -16,7 +16,7 @@
- public:
-
- QString m_strDirName;
-- QMDS *m_pMds;
-+ class QMDS *m_pMds;
- MDS_DB_HANDLE m_hDb;
-
- CSSM_RETURN Open( QMDS *pMds, const char *szDirName );
diff --git a/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch b/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch
deleted file mode 100644
index 3b778ce6ac99..000000000000
--- a/sys-auth/pam_bioapi/files/pam_bioapi.c-0.2.1.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- libpam_bioapi/pam_bioapi.c 2005-10-24 17:31:26.000000000 +0200
-+++ libpam_bioapi/pam_bioapi.c.patched 2005-10-24 17:33:25.000000000 +0200
-@@ -54,6 +54,7 @@
- BioAPI_HANDLE bspHandle;
- BioAPI_INPUT_BIR BIR;
- BioAPI_BOOL result = BioAPI_FALSE;
-+ BioAPI_BOOL bPrecedence = BioAPI_TRUE;
- BioAPI_FAR FARAchieved;
- BioAPI_UUID tempUuid;
- const BioAPI_UUID *uuid;
-@@ -143,7 +144,7 @@
-
- tries = 3;
- do {
-- bRet = BioAPI_Verify(bspHandle, &maxFAR, NULL, NULL, &BIR, NULL, &result, &FARAchieved, NULL, NULL, -1, NULL);
-+ bRet = BioAPI_Verify(bspHandle, &maxFAR, NULL, &bPrecedence, &BIR, NULL, &result, &FARAchieved, NULL, NULL, -1, NULL);
- switch(bRet) {
- case BioAPI_OK:
- if (result == BioAPI_TRUE) {
-@@ -370,7 +371,7 @@
- }
-
- bytesRead = fread(&(tempBir->Header), bytes, 1, inputFile);
-- bytes = (tempBir->Header.Length) - sizeof(BioAPI_DATA);
-+ bytes = (tempBir->Header.Length) - sizeof(BioAPI_BIR_HEADER);
- tempBir->BiometricData = (BioAPI_BIR_BIOMETRIC_DATA_PTR)malloc(bytes);
- if (tempBir->BiometricData == 0) {
- syslog(LOG_ALERT, "Unable to allocate memory.");
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild
deleted file mode 100644
index 2b024bbbb788..000000000000
--- a/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.2.1-r1.ebuild,v 1.1 2007/02/26 04:17:17 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="PAM interface for biometric auth"
-HOMEPAGE="http://www.qrivy.net/~michael/blua/"
-SRC_URI="http://www.qrivy.net/~michael/blua/pam_bioapi/${P}.tar.bz2
- http://upir.cz/linux/patches/${P}-alter-environ.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="sys-auth/bioapi
- sys-libs/pam
- sys-auth/tfm-fingerprint"
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/pam_bioapi.c-${PV}.patch
- epatch "${DISTDIR}"/${P}-alter-environ.patch
-}
-
-src_compile() {
- export CPPFLAGS="${CPPFLAGS} -I/opt/bioapi/include"
- econf --prefix=/ || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "einstall failed"
- find "${D}" -name '*.la' -print0 | xargs -0 rm
- dodir /usr
- mv "${D}"/bin "${D}"/usr/bin || die
-}