summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-12-29 04:22:44 +0000
committerJason Wever <weeve@gentoo.org>2003-12-29 04:22:44 +0000
commit883e9305404f3991dc31cd980f54b39222972273 (patch)
tree54661373beaab35126e6a1d08c5d20aa1ca31b5f /sys-boot/silo
parentAdded the mount-boot eclass to the silo ebuilds. Thanks for fo0bar from #gen... (diff)
downloadhistorical-883e9305404f3991dc31cd980f54b39222972273.tar.gz
historical-883e9305404f3991dc31cd980f54b39222972273.tar.bz2
historical-883e9305404f3991dc31cd980f54b39222972273.zip
Added the mount-boot eclass to the silo ebuilds. Thanks for fo0bar from #gentoo-sparc for pointing this out. Also fixed ebuilds so maketilo manpage gets installed in such a fashion that it's usable.
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/Manifest6
-rw-r--r--sys-boot/silo/files/digest-silo-1.3.1-r11
-rw-r--r--sys-boot/silo/files/digest-silo-1.3.2-r11
-rw-r--r--sys-boot/silo/silo-1.3.1-r1.ebuild32
-rw-r--r--sys-boot/silo/silo-1.3.2-r1.ebuild32
5 files changed, 69 insertions, 3 deletions
diff --git a/sys-boot/silo/Manifest b/sys-boot/silo/Manifest
index 5759e33dd35d..d855eeb1f08a 100644
--- a/sys-boot/silo/Manifest
+++ b/sys-boot/silo/Manifest
@@ -1,10 +1,10 @@
-MD5 2cab254c59432aa7637de608532a0f35 ChangeLog 2255
+MD5 b1d15c05441a43cd24288669ca334b63 ChangeLog 2583
MD5 64e92dc3614963db8a397f670749b6cf metadata.xml 369
MD5 f836042e500318f15fd92300511bd442 silo-1.3.0-r1.ebuild 1052
MD5 e004aca64f3d5e787c0f90e27ed74765 silo-1.3.1.ebuild 696
MD5 6ab40568bfafd7a794b00213a971e63e silo-1.3.2.ebuild 699
-MD5 20279798daaf94a2165bd894bdb7b430 silo-1.3.2-r1.ebuild 848
-MD5 c321d538bc5bfde4c1cfe9d533654fe5 silo-1.3.1-r1.ebuild 845
+MD5 b4c3b9069e3a670a6668575e96654648 silo-1.3.2-r1.ebuild 849
+MD5 8e08c18570aeaa1cb874b46ae8e0b847 silo-1.3.1-r1.ebuild 848
MD5 83abd0a2622029e47ae371fbbe8e7f32 files/digest-silo-1.3.0-r1 62
MD5 d64a6c9a2051c74be817cf525ead4db5 files/digest-silo-1.3.1 62
MD5 ba569526e64ff4aae31e2eb37150f62d files/digest-silo-1.3.2 62
diff --git a/sys-boot/silo/files/digest-silo-1.3.1-r1 b/sys-boot/silo/files/digest-silo-1.3.1-r1
new file mode 100644
index 000000000000..d320b686572a
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.3.1-r1
@@ -0,0 +1 @@
+MD5 3e3438ed97e5600e1741ab3905600c69 silo-1.3.1.tar.gz 172803
diff --git a/sys-boot/silo/files/digest-silo-1.3.2-r1 b/sys-boot/silo/files/digest-silo-1.3.2-r1
new file mode 100644
index 000000000000..725ea856c410
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.3.2-r1
@@ -0,0 +1 @@
+MD5 1f27537cf7ba28d482493725758c3ebf silo-1.3.2.tar.gz 172798
diff --git a/sys-boot/silo/silo-1.3.1-r1.ebuild b/sys-boot/silo/silo-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..b08bcba8326b
--- /dev/null
+++ b/sys-boot/silo/silo-1.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.3.1-r1.ebuild,v 1.1 2003/12/29 04:22:36 weeve Exp $
+
+inherit mount-boot
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* sparc"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+src_compile() {
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
diff --git a/sys-boot/silo/silo-1.3.2-r1.ebuild b/sys-boot/silo/silo-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..d478f726f9bb
--- /dev/null
+++ b/sys-boot/silo/silo-1.3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.3.2-r1.ebuild,v 1.1 2003/12/29 04:22:36 weeve Exp $
+
+inherit mount-boot
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+src_compile() {
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}