summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-06 04:03:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-06 04:03:50 +0000
commite9074c4f25d3c2577423632d1045d07f685d0e24 (patch)
treef73fc17fe11fb9d015ea9d89de81156019cfbcc9 /sys-boot
parentold (diff)
downloadhistorical-e9074c4f25d3c2577423632d1045d07f685d0e24.tar.gz
historical-e9074c4f25d3c2577423632d1045d07f685d0e24.tar.bz2
historical-e9074c4f25d3c2577423632d1045d07f685d0e24.zip
Fix building with newer binutils and clean up the src_install to use Gentoo style install.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog11
-rw-r--r--sys-boot/elilo/Manifest17
-rw-r--r--sys-boot/elilo/elilo-3.4-r2.ebuild58
-rw-r--r--sys-boot/elilo/files/digest-elilo-3.4-r21
-rw-r--r--sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch15
5 files changed, 92 insertions, 10 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index a10bfec38ba9..4f7dbd1c6fcf 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/elilo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.8 2005/03/30 19:50:57 plasmaroo Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.9 2005/05/06 04:03:50 vapier Exp $
+
+*elilo-3.4-r2 (06 May 2005)
+
+ 06 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/elilo-3.4-proc-sigsetjmp.patch, +elilo-3.4-r2.ebuild:
+ Fix building with newer binutils and clean up the src_install to use Gentoo
+ style install.
*elilo-3.4-r1 (30 Mar 2005)
diff --git a/sys-boot/elilo/Manifest b/sys-boot/elilo/Manifest
index b47607609962..fd0ee3487dee 100644
--- a/sys-boot/elilo/Manifest
+++ b/sys-boot/elilo/Manifest
@@ -1,11 +1,12 @@
-MD5 f454ea5f02df63b83aa3fa8c34053798 ChangeLog 1120
-MD5 20991ffcb681a67b533700cafde1a6f9 elilo-3.4.ebuild 1779
+MD5 ceba62115d912083adc7373c18a52e09 ChangeLog 1355
+MD5 61f2b0ff98042408f8fbe4020a2cde81 elilo-3.4-r2.ebuild 1664
MD5 46b23f2a5ba4295b08bad2462a1f120e elilo-3.4-r1.ebuild 1782
-MD5 a479f5334497679bd91ddc7181866f52 files/eliloalt.8-3.4 550
-MD5 2b2d58955c4ad612fee3bcf9b977bc41 files/elilo-3.4-makefile.patch 338
-MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4-r1 61
-MD5 b8d17fae7a7884645a7f89b31129e3d0 files/elilo.conf.sample 161
-MD5 5e611594843275c52c4b4921b89a23e4 files/elilo.8-3.4 3286
MD5 2640f713f5f00cf0a17e31d220c8242c files/elilo-3.3a-devscheme.patch 3571
MD5 821c2877ad33567d7c7dc9598331e7f9 files/elilo-3.4 22782
-MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4 61
+MD5 2b2d58955c4ad612fee3bcf9b977bc41 files/elilo-3.4-makefile.patch 338
+MD5 5e611594843275c52c4b4921b89a23e4 files/elilo.8-3.4 3286
+MD5 b8d17fae7a7884645a7f89b31129e3d0 files/elilo.conf.sample 161
+MD5 a479f5334497679bd91ddc7181866f52 files/eliloalt.8-3.4 550
+MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4-r1 61
+MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4-r2 61
+MD5 d8b9c6b6a99161eaad38eae80039af69 files/elilo-3.4-proc-sigsetjmp.patch 374
diff --git a/sys-boot/elilo/elilo-3.4-r2.ebuild b/sys-boot/elilo/elilo-3.4-r2.ebuild
new file mode 100644
index 000000000000..c6bbc5524500
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.4-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r2.ebuild,v 1.1 2005/05/06 04:03:50 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/elilo-3.4-makefile.patch
+ epatch "${FILESDIR}"/elilo-3.4-proc-sigsetjmp.patch
+ epatch "${FILESDIR}"/elilo-3.3a-devscheme.patch
+}
+
+src_compile() {
+ local iarch
+ case $(tc-arch) in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $(tc-arch)" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+}
+
+src_install() {
+ newsbin "${FILESDIR}"/elilo-${PV} elilo || die "elilo failed"
+ dosbin tools/eliloalt || die "eliloalt failed"
+
+ exeinto /usr/lib/elilo
+ doexe elilo.efi || die "elilo.efi failed"
+
+ if [[ ! -e ${D}/etc/elilo.conf ]] ; then
+ insinto /etc
+ newins "${FILESDIR}"/elilo.conf.sample elilo.conf
+ fi
+
+ dodoc docs/* "${FILESDIR}"/elilo.conf.sample
+ newman "${FILESDIR}"/elilo.8-${PV} elilo.8
+ newman "${FILESDIR}"/eliloalt.8-${PV} eliloalt.8
+}
diff --git a/sys-boot/elilo/files/digest-elilo-3.4-r2 b/sys-boot/elilo/files/digest-elilo-3.4-r2
new file mode 100644
index 000000000000..6c9603e2135d
--- /dev/null
+++ b/sys-boot/elilo/files/digest-elilo-3.4-r2
@@ -0,0 +1 @@
+MD5 e7357929dfca29436d35ad6386fc051c elilo-3.4.tar.gz 316518
diff --git a/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch b/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch
new file mode 100644
index 000000000000..5796b0f05d13
--- /dev/null
+++ b/sys-boot/elilo/files/elilo-3.4-proc-sigsetjmp.patch
@@ -0,0 +1,15 @@
+Fix an error with newer binutils:
+
+setjmp.S: Assembler messages:
+setjmp.S:170: Error: .endp outside of procedure
+
+--- elilo-3.4/ia64/setjmp.S
++++ elilo-3.4/ia64/setjmp.S
+@@ -78,6 +78,7 @@
+
+ /* __sigsetjmp(__jmp_buf buf, int savemask) */
+
++ .proc __sigsetjmp
+ __sigsetjmp:
+ //.prologue ASM_UNW_PRLG_RP|ASM_UNW_PRLG_PFS, ASM_UNW_PRLG_GRSAVE(2)
+ alloc loc1=ar.pfs,2,2,2,0