summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-10-15 10:59:38 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-10-15 10:59:38 +0000
commit354c3385450ada54439bc23d36df13f4f9aa96d1 (patch)
tree76f2802495976eb5641ff4b52b351dba8d89745d /sys-cluster/gulm/gulm-1.03.00.ebuild
parentEbuild cleanup, removed check_KV. (diff)
downloadhistorical-354c3385450ada54439bc23d36df13f4f9aa96d1.tar.gz
historical-354c3385450ada54439bc23d36df13f4f9aa96d1.tar.bz2
historical-354c3385450ada54439bc23d36df13f4f9aa96d1.zip
Ebuild cleanup, version bump.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'sys-cluster/gulm/gulm-1.03.00.ebuild')
-rw-r--r--sys-cluster/gulm/gulm-1.03.00.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-cluster/gulm/gulm-1.03.00.ebuild b/sys-cluster/gulm/gulm-1.03.00.ebuild
new file mode 100644
index 000000000000..69ffd0de2d3e
--- /dev/null
+++ b/sys-cluster/gulm/gulm-1.03.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gulm/gulm-1.03.00.ebuild,v 1.1 2006/10/15 10:59:38 xmerlin Exp $
+
+inherit linux-mod
+
+CLUSTER_VERSION="1.03.00"
+DESCRIPTION="Redundant server-based cluster and lock manager for GFS"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/cluster-${CLUSTER_VERSION}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+
+DEPEND=">=sys-cluster/ccs-1.03.00
+ >=sys-cluster/cman-1.03.00
+ sys-apps/tcp-wrappers
+ "
+
+RDEPEND="sys-apps/tcp-wrappers"
+
+
+S="${WORKDIR}/cluster-${CLUSTER_VERSION}/${PN}"
+
+src_compile() {
+ ./configure --kernel_src=/usr/src/linux || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install problem"
+
+ rm -f ${D}/etc/init.d/lock_gulmd
+}