summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2004-08-16 07:49:54 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2004-08-16 07:49:54 +0000
commit4bd733e7cf3b993e9c979f5c5aeb536cc7f3b98f (patch)
tree7b4553709a16f6f1af53140f22caca0ee07b4e76 /sys-cluster
parentGot rid of the patch in favor of flag-o-matic (diff)
downloadhistorical-4bd733e7cf3b993e9c979f5c5aeb536cc7f3b98f.tar.gz
historical-4bd733e7cf3b993e9c979f5c5aeb536cc7f3b98f.tar.bz2
historical-4bd733e7cf3b993e9c979f5c5aeb536cc7f3b98f.zip
initial revision
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pconsole/ChangeLog11
-rw-r--r--sys-cluster/pconsole/Manifest5
-rw-r--r--sys-cluster/pconsole/files/digest-pconsole-1.01
-rw-r--r--sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch10
-rw-r--r--sys-cluster/pconsole/metadata.xml11
-rw-r--r--sys-cluster/pconsole/pconsole-1.0.ebuild33
6 files changed, 71 insertions, 0 deletions
diff --git a/sys-cluster/pconsole/ChangeLog b/sys-cluster/pconsole/ChangeLog
new file mode 100644
index 000000000000..3475f6debe81
--- /dev/null
+++ b/sys-cluster/pconsole/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-cluster/openmosix-user
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/ChangeLog,v 1.1 2004/08/16 07:49:54 voxus Exp $
+
+*pconsole-1.0 (16 Aug 2004)
+
+ 16 Aug 2004; Konstantin Arkhipov <voxus@gentoo.org>
+ +pconsole-1.0.ebuild,
+ +files/pconsole-1.0-exit-warn.patch:
+ Initial release. Ebuild submitted by Jesse Becker <jbecker@speakeasy.net>.
+ Trivial patch to avoid compilation warning.
diff --git a/sys-cluster/pconsole/Manifest b/sys-cluster/pconsole/Manifest
new file mode 100644
index 000000000000..9c1d723fa4e7
--- /dev/null
+++ b/sys-cluster/pconsole/Manifest
@@ -0,0 +1,5 @@
+MD5 b88642823f0f5c0f2c8d1bd04b5255e0 pconsole-1.0.ebuild 837
+MD5 cc372505a1bbc4e0d11fc1e8918c538d ChangeLog 487
+MD5 beb9efce81ae2c582a621528fc783095 metadata.xml 373
+MD5 831ce0c1ca12bf4f0ee512f433507741 files/pconsole-1.0-exit-warn.patch 248
+MD5 3cd29c35b2fc6d527133bbb43884ad91 files/digest-pconsole-1.0 64
diff --git a/sys-cluster/pconsole/files/digest-pconsole-1.0 b/sys-cluster/pconsole/files/digest-pconsole-1.0
new file mode 100644
index 000000000000..c5452b3be151
--- /dev/null
+++ b/sys-cluster/pconsole/files/digest-pconsole-1.0
@@ -0,0 +1 @@
+MD5 b0a170284c3272e2e403fc8f2ccfdd53 pconsole-1.0.tar.gz 215426
diff --git a/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch b/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch
new file mode 100644
index 000000000000..f306d6408ee8
--- /dev/null
+++ b/sys-cluster/pconsole/files/pconsole-1.0-exit-warn.patch
@@ -0,0 +1,10 @@
+--- pconsole.c 2001-04-09 12:51:49.000000000 +0400
++++ pconsole.c~vox 2004-08-16 11:37:49.606267087 +0400
+@@ -28,6 +28,7 @@
+ #include "Conn.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <errno.h>
+ #include <signal.h>
diff --git a/sys-cluster/pconsole/metadata.xml b/sys-cluster/pconsole/metadata.xml
new file mode 100644
index 000000000000..2216ac015a32
--- /dev/null
+++ b/sys-cluster/pconsole/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<maintainer>
+ <email>tantive@gentoo.org</email>
+<!-- <name>Michael Imhof</name> -->
+<!-- <description>Release manager, patch manager</description> -->
+</maintainer>
+<!-- <longdescription></longdescription> -->
+</pkgmetadata>
diff --git a/sys-cluster/pconsole/pconsole-1.0.ebuild b/sys-cluster/pconsole/pconsole-1.0.ebuild
new file mode 100644
index 000000000000..7c996d346857
--- /dev/null
+++ b/sys-cluster/pconsole/pconsole-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/pconsole-1.0.ebuild,v 1.1 2004/08/16 07:49:54 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for managing multiple xterms simultaneously."
+HOMEPAGE="http://www.heiho.net/pconsole/"
+SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/ssh"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-exit-warn.patch || einfo "Never mind.."
+ ./configure --prefix=${D}/usr
+ emake || die
+}
+
+src_install() {
+ dobin pconsole pconsole.sh
+ fperms 4111 /usr/bin/pconsole
+ dodoc ChangeLog public_html/pconsole.html README.pconsole
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Warning:"
+ ewarn "pconsole installed with suid root!"
+ ewarn
+}