summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-04 22:59:25 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-04 22:59:25 +0000
commit65f2d4618004df314dbdeeef628fae12f20f0789 (patch)
treef196f94d56e37e09f79821bdf4f64da6afe9808e /sys-devel/autoconf/autoconf-2.67.ebuild
parentDrop automake-1.9 requirement #454750 by Alphat-PC. (diff)
downloadhistorical-65f2d4618004df314dbdeeef628fae12f20f0789.tar.gz
historical-65f2d4618004df314dbdeeef628fae12f20f0789.tar.bz2
historical-65f2d4618004df314dbdeeef628fae12f20f0789.zip
Initial USE=multislot support. Also drop -j1 workaround for newer versions as bug only affected 2.61.
Package-Manager: portage-2.2.0_alpha170/cvs/Linux x86_64 Manifest-Sign-Key: 0xFB7C4156
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.67.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.67.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/sys-devel/autoconf/autoconf-2.67.ebuild b/sys-devel/autoconf/autoconf-2.67.ebuild
index 3891ced3df7f..495fcc88e59d 100644
--- a/sys-devel/autoconf/autoconf-2.67.ebuild
+++ b/sys-devel/autoconf/autoconf-2.67.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.67.ebuild,v 1.12 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.67.ebuild,v 1.13 2013/04/04 22:59:16 vapier Exp $
EAPI="2"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/autoconf.git"
- inherit git
+ inherit git-2
SRC_URI=""
#KEYWORDS=""
else
@@ -19,8 +21,8 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT="2.5"
-IUSE="emacs"
+SLOT=$(usex multislot "${PV}" "2.5")
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -32,6 +34,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -47,4 +50,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}