summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-05 15:15:02 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-05 15:15:02 +0000
commit5efde6e611a35cd31b78a34f0e89b20571e654c9 (patch)
treedc47bf182c35d693eecce06acb7615cb23d81d65 /sys-devel/bc/bc-1.06.95.ebuild
parentold (diff)
downloadhistorical-5efde6e611a35cd31b78a34f0e89b20571e654c9.tar.gz
historical-5efde6e611a35cd31b78a34f0e89b20571e654c9.tar.bz2
historical-5efde6e611a35cd31b78a34f0e89b20571e654c9.zip
Version bump for #136643.
Package-Manager: portage-2.1.1_rc1-r4
Diffstat (limited to 'sys-devel/bc/bc-1.06.95.ebuild')
-rw-r--r--sys-devel/bc/bc-1.06.95.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/bc/bc-1.06.95.ebuild b/sys-devel/bc/bc-1.06.95.ebuild
new file mode 100644
index 000000000000..5b84453428fb
--- /dev/null
+++ b/sys-devel/bc/bc-1.06.95.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06.95.ebuild,v 1.1 2006/09/05 15:15:02 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Handy console-based calculator utility"
+HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/bc/${P}.tar.bz2
+ mirror://gnu/bc/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="libedit readline static"
+
+RDEPEND="readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ libedit? ( || ( sys-freebsd/freebsd-lib dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ local myconf
+ if use readline ; then
+ myconf="--with-readline --without-libedit"
+ elif use libedit ; then
+ myconf="--without-readline --with-libedit"
+ else
+ myconf="--without-readline --without-libedit"
+ fi
+ use static && append-ldflags -static
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS FAQ NEWS README ChangeLog
+}