summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-10 01:04:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-10 01:04:25 +0000
commitb0d5fc8abc3c126b296e1c0cfea5d9ffc4d81623 (patch)
treebe6bf48ac8e855a9417b4df782ae1028ecfc099d /sys-devel/crossdev
parentexport ABI to x86 #81082 (diff)
downloadhistorical-b0d5fc8abc3c126b296e1c0cfea5d9ffc4d81623.tar.gz
historical-b0d5fc8abc3c126b296e1c0cfea5d9ffc4d81623.tar.bz2
historical-b0d5fc8abc3c126b296e1c0cfea5d9ffc4d81623.zip
make sure we work when using multiple overlays
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest2
-rwxr-xr-xsys-devel/crossdev/files/crossdev3
2 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index c748934642a9..494443032d0c 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -3,4 +3,4 @@ MD5 e91cdaf464f515f3528da02cf06e54a1 metadata.xml 222
MD5 c0cf28d66474b3d795a4d574033be962 crossdev-0.9.5-r1.ebuild 557
MD5 bbb032e270728ffb39276e95e5653b62 files/crossdev-0.4-fixes-one.patch 1675
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-crossdev-0.9.5-r1 0
-MD5 3684c986849054365b474d42e01282f8 files/crossdev 9818
+MD5 274e3012c75485e0afbae3155bdff233 files/crossdev 9858
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 8c6079455f8a..af3bbaddb832 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.18 2005/04/05 23:17:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.19 2005/04/10 01:04:25 vapier Exp $
if [[ ${ROOT:-/} != "/" ]] ; then
echo "Sorry, but crossdev does not support ROOT."
@@ -95,6 +95,7 @@ parse_target() {
setup_portage_vars() {
PORTDIR_OVERLAY=$(portageq envvar PORTDIR_OVERLAY)
+ PORTDIR_OVERLAY=${PORTDIR_OVERLAY%% *}
PORTDIR=$(portageq envvar PORTDIR)
PORT_LOGDIR=$(portageq envvar PORT_LOGDIR)
PORT_LOGDIR=${PORT_LOGDIR:-/var/log/portage}