summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-26 01:32:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-26 01:32:09 +0000
commit72f352052afd1fe435e66c3c04cfc3b8c1bd590f (patch)
tree49fb70278f7ee1c1e2df7bf9108c5ec8be889dfd /sys-devel/gettext/gettext-0.16.1.ebuild
parentStable for HPPA (bug #165555). (diff)
downloadhistorical-72f352052afd1fe435e66c3c04cfc3b8c1bd590f.tar.gz
historical-72f352052afd1fe435e66c3c04cfc3b8c1bd590f.tar.bz2
historical-72f352052afd1fe435e66c3c04cfc3b8c1bd590f.zip
Use preserve_old_lib rather than screwing with $ROOT ourselves #168046.
Package-Manager: portage-2.1.2-r10
Diffstat (limited to 'sys-devel/gettext/gettext-0.16.1.ebuild')
-rw-r--r--sys-devel/gettext/gettext-0.16.1.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/sys-devel/gettext/gettext-0.16.1.ebuild b/sys-devel/gettext/gettext-0.16.1.ebuild
index c9754b498df4..f8d05e35dc28 100644
--- a/sys-devel/gettext/gettext-0.16.1.ebuild
+++ b/sys-devel/gettext/gettext-0.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.16.1.ebuild,v 1.10 2007/02/21 18:16:35 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.16.1.ebuild,v 1.11 2007/02/26 01:32:09 vapier Exp $
inherit flag-o-matic eutils multilib toolchain-funcs mono libtool elisp-common
@@ -71,21 +71,7 @@ src_install() {
fi
rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
- # older gettext's sometimes installed libintl ...
- # need to keep the linked version or the system
- # could die (things like sed link against it :/)
- local libname="libintl$(get_libname 7)"
- if [[ -e ${ROOT}/usr/$(get_libdir)/${libname} ]] ; then
- cp -pPR ${ROOT}/usr/$(get_libdir)/${libname}* "${D}"/usr/$(get_libdir)/
- touch "${D}"/usr/$(get_libdir)/${libname}*
- fi
- if [[ -e ${ROOT}/$(get_libdir)/${libname} ]] ; then
- dodir /$(get_libdir)
- cp -pPR ${ROOT}/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
- touch "${D}"/$(get_libdir)/${libname}*
- fi
-
- if [[ $USERLAND == "BSD" ]] ; then
+ if [[ ${USERLAND} == "BSD" ]] ; then
libname="libintl$(get_libname 8)"
# Move dynamic libs and creates ldscripts into /usr/lib
dodir /$(get_libdir)
@@ -110,6 +96,13 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README THANKS
}
+pkg_preinst() {
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ preserve_old_lib /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
+
pkg_postinst() {
use emacs && elisp-site-regen
ewarn "Any package that linked against the previous version"