summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-14 11:40:29 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-14 11:40:29 +0000
commitcf4a8ae2a27545abb5b97408328e4d4a13849fa0 (patch)
treeb0c11d5a2582447c2c8b9b634672e4b9ff6f1357 /sys-devel/libtool
parentSWIG 1.3.10 (diff)
downloadhistorical-cf4a8ae2a27545abb5b97408328e4d4a13849fa0.tar.gz
historical-cf4a8ae2a27545abb5b97408328e4d4a13849fa0.tar.bz2
historical-cf4a8ae2a27545abb5b97408328e4d4a13849fa0.zip
updated to 1.4.2, apply patch that makes linking faster, noticable when merging evolution, will mask this one for now
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/files/digest-libtool-1.4.21
-rw-r--r--sys-devel/libtool/files/libtool-1.4.2.ltmain.sh-hack.diff20
-rw-r--r--sys-devel/libtool/libtool-1.4.2.ebuild30
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-devel/libtool/files/digest-libtool-1.4.2 b/sys-devel/libtool/files/digest-libtool-1.4.2
new file mode 100644
index 000000000000..18d962467c66
--- /dev/null
+++ b/sys-devel/libtool/files/digest-libtool-1.4.2
@@ -0,0 +1 @@
+MD5 95dd3de3b249fe1199ed60ed8e46f60c libtool-1.4.2.tar.gz 1187840
diff --git a/sys-devel/libtool/files/libtool-1.4.2.ltmain.sh-hack.diff b/sys-devel/libtool/files/libtool-1.4.2.ltmain.sh-hack.diff
new file mode 100644
index 000000000000..6fa99486a3f5
--- /dev/null
+++ b/sys-devel/libtool/files/libtool-1.4.2.ltmain.sh-hack.diff
@@ -0,0 +1,20 @@
+--- /usr/share/libtool/ltmain.sh Sat May 12 19:29:42 2001
++++ ./ltmain.sh Wed May 23 20:02:10 2001
+@@ -1530,6 +1530,8 @@
+ convenience="$convenience $ladir/$objdir/$old_library"
+ old_convenience="$old_convenience $ladir/$objdir/$old_library"
+ tmp_libs=
++ # PKGW
++ dependency_libs=
+ for deplib in $dependency_libs; do
+ deplibs="$deplib $deplibs"
+ case "$tmp_libs " in
+@@ -1645,6 +1647,8 @@
+ fi
+
+ tmp_libs=
++ #PKGW
++ dependency_libs=
+ for deplib in $dependency_libs; do
+ case $deplib in
+ -L*) newlib_search_path="$newlib_search_path "`$echo "X$deplib" | $Xsed -e 's/^-L//'`;; ### testsuite: skip nested quoting test
diff --git a/sys-devel/libtool/libtool-1.4.2.ebuild b/sys-devel/libtool/libtool-1.4.2.ebuild
new file mode 100644
index 000000000000..25be9caa63a7
--- /dev/null
+++ b/sys-devel/libtool/libtool-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.2.ebuild,v 1.1 2002/01/14 11:40:29 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A shared library tool for developers"
+SRC_URI="ftp://ftp.sunet.se/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info
+ assert
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog* NEWS \
+ README THANKS TODO doc/PLATFORMS
+
+ cd ${D}/usr/share/libtool
+ patch -p0 < ${FILESDIR}/${PN}-${PV}.ltmain.sh-hack.diff
+}