summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-09 21:23:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-09 21:23:12 +0000
commitee63d8fa0e9a82e894d1f55c7d07ead014186c40 (patch)
tree43818aff6ef66a6b81b39e7dfcb446f7c9c27517 /sys-devel/libtool
parentVersion bump, closes bug #70499. (diff)
downloadhistorical-ee63d8fa0e9a82e894d1f55c7d07ead014186c40.tar.gz
historical-ee63d8fa0e9a82e894d1f55c7d07ead014186c40.tar.bz2
historical-ee63d8fa0e9a82e894d1f55c7d07ead014186c40.zip
Update the .so and tag guessing patches.
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/ChangeLog8
-rw-r--r--sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch14
-rw-r--r--sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch35
-rw-r--r--sys-devel/libtool/libtool-1.5.10.ebuild98
4 files changed, 71 insertions, 84 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 7af762368b95..52465775281e 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/libtool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.58 2004/11/09 16:33:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.59 2004/11/09 21:23:12 vapier Exp $
+
+ 09 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.5.6/libtool-1.5-filter-host-tags.patch,
+ +files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch,
+ libtool-1.5.10.ebuild:
+ Update the .so and tag guessing patches.
09 Nov 2004; Mike Frysinger <vapier@gentoo.org> +libtool-1.3.5.ebuild:
SLOT-ed version of libtool, no point in building 1.3.5 all the time.
diff --git a/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch b/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch
new file mode 100644
index 000000000000..ccaa25f7264c
--- /dev/null
+++ b/sys-devel/libtool/files/1.5.6/libtool-1.5-filter-host-tags.patch
@@ -0,0 +1,14 @@
+--- libtool-1.5.10/ltmain.in.orig 2004-11-09 13:43:24.290875562 -0500
++++ libtool-1.5.10/ltmain.in 2004-11-09 13:45:51.250048464 -0500
+@@ -242,7 +242,11 @@
+ esac
+ CC_quoted="$CC_quoted $arg"
+ done
++ # user sometimes does CC=<HOST>-gcc so we need to match that to 'gcc'
++ trimedcc="${CC/${host}-}"
+ case "$@ " in
++ "gcc "* | " gcc "* | "${host}-gcc "* | " ${host}-gcc "*) tagname=CC ; break ;;
++ "$trimedcc "* | " $trimedcc "* | "`$echo $trimedcc` "* | " `$echo $trimedcc` "*|\
+ " $CC "* | "$CC "* | " `$echo $CC` "* | "`$echo $CC` "* | " $CC_quoted"* | "$CC_quoted "* | " `$echo $CC_quoted` "* | "`$echo $CC_quoted` "*)
+ # The compiler in the base compile command matches
+ # the one in the tagged configuration.
diff --git a/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch b/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch
new file mode 100644
index 000000000000..ba46f009af18
--- /dev/null
+++ b/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch
@@ -0,0 +1,35 @@
+--- libtool-1.5.2/libtool.m4 2004-02-10 00:23:58.000000000 +0200
++++ libtool-1.5.2.shared_ext/libtool.m4 2004-02-10 23:32:08.364266152 +0200
+@@ -229,6 +229,7 @@
+ tagname=
+ AC_LIBTOOL_LANG_C_CONFIG
+ _LT_AC_TAGCONFIG
++_LT_AC_SHARED_EXT
+ ])# AC_LIBTOOL_SETUP
+
+
+@@ -1788,6 +1789,24 @@
+ fi
+ ])# _LT_AC_TAGCONFIG
+
++# _LT_AC_SHARED_EXT
++# ----------------
++AC_DEFUN([_LT_AC_SHARED_EXT],[
++ if test ! -f "${ofile}"; then
++ AC_MSG_WARN([output file `$ofile' does not exist])
++ fi
++ if test -z "`grep -e 'shared_ext.*shrext_cmds' $ofile`"; then
++ # Make sure $shared_ext gets set to $shrext_cmds
++ if sed -e 's/shared_ext/shrext_cmds/g' "$ofile" > "${ofile}T"; then
++ mv "${ofile}T" "$ofile"
++ chmod +x "$ofile"
++ else
++ rm -f "${ofile}T"
++ AC_MSG_ERROR([unable to update shared_ext.])
++ fi
++ fi
++])# _LT_AC_SHARED_EXT
++
+
+ # AC_LIBTOOL_DLOPEN
+ # -----------------
diff --git a/sys-devel/libtool/libtool-1.5.10.ebuild b/sys-devel/libtool/libtool-1.5.10.ebuild
index eab167a4b91d..cd1b7042de60 100644
--- a/sys-devel/libtool/libtool-1.5.10.ebuild
+++ b/sys-devel/libtool/libtool-1.5.10.ebuild
@@ -1,20 +1,15 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10.ebuild,v 1.2 2004/11/06 06:18:57 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10.ebuild,v 1.3 2004/11/09 21:23:12 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
-inherit eutils gnuconfig
+inherit eutils gnuconfig libtool
-# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
-
-OLD_PV="1.3.5"
-OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
- mirror://gnu/${PN}/${PN}-${OLD_PV}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="1.5"
# breaks building .so completely (emerge fam)
KEYWORDS="-*"
#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
@@ -56,32 +51,11 @@ src_unpack() {
unpack ${A}
- cd ${OLD_S}
- echo
- # Install updated missing script
- portageq has_version / "sys-devel/automake" && {
- rm -f missing
- automake --add-missing
- }
-
- einfo "Patching ${OLD_S##*/} ..."
- epatch ${FILESDIR}/1.4.3/${PN}-1.2f-cache.patch
- epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
- epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
- epatch ${FILESDIR}/ltconfig-uclibc.patch
-
cd ${S}
- echo
- # Install updated missing script
-# portageq has_version / "sys-devel/automake" && {
-# rm -f missing
-# automake --add-missing
-# }
# Make sure non of the patches touch ltmain.sh, but rather ltmain.in
rm -f ltmain.sh*
- einfo "Patching ${S##*/} ..."
# Redhat patches
epatch ${FILESDIR}/1.4.3/${PN}-1.4-nonneg.patch
# Fix the relink problem where the relinked libs do not get
@@ -122,7 +96,7 @@ src_unpack() {
# issue where $shared_ext is not set. This results in libraries
# being built without '.so' extension, bug #40901
# <azarah@gentoo.org> - (11 Feb 2004)
- epatch ${FILESDIR}/1.5.2/${PN}-1.5.2-libtool_m4-shared_ext.patch
+ epatch ${FILESDIR}/1.5.6/${PN}-1.5.6-libtool_m4-shared_ext.patch
# For older autoconf setups's that do not support libtool.m4,
# $max_cmd_len are never set, causing all tests against it to
# fail, resulting in 'integer expression expected' errors and
@@ -130,67 +104,28 @@ src_unpack() {
# <azarah@gentoo.org> - (11 Feb 2004)
epatch ${FILESDIR}/1.5.2/${PN}-1.5.2-ltmain_sh-max_cmd_len.patch
+ # Libtool's autoguessing at tag's sucks ... it get's confused
+ # if the tag's CC says '<CHOST>-gcc' and the env CC says 'gcc'
+ # or vice versa ... newer automakes specify the tag so no
+ # guessing is needed #67692
+ epatch ${FILESDIR}/1.5.6/libtool-1.5-filter-host-tags.patch
+
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
- # Run gnuconfig_update for both old and new versions *after* patches so we
- # don't screw them up
+ uclibctoolize
gnuconfig_update ${WORKDIR}
}
src_compile() {
lt_setup
-
- #
- # ************ libtool-1.3x ************
- #
-
- cd ${OLD_S}
-
- einfo "Configuring ${OLD_S##*/} ..."
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info || die
-
- einfo "Building ${OLD_S##*/} ..."
- emake || die
-
- #
- # ************ libtool-1.5x ************
- #
-
- cd ${S}
-
- einfo "Configuring ${S##*/} ..."
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info || die
-
- einfo "Building ${S##*/} ..."
+ econf || die
emake || die
}
src_install() {
- #
- # ************ libtool-1.3x ************
- #
-
- einfo "Installing ${OLD_S##*/} ..."
- cd ${OLD_S}/libltdl; make DESTDIR=${D} install || die
-
- # Remove stuff we are not going to use ...
- for x in libltdl.a libltdl.la libltdl.so
- do
- [ -f ${x} ] && rm -f ${D}/usr/lib/${x}
- done
- rm -rf ${D}/usr/include
-
- #
- # ************ libtool-1.5x ************
- #
-
- einfo "Installing ${S##*/} ..."
- cd ${S}; make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
if use uclibc ; then
for x in $(find ${D} -name config.guess -o -name config.sub) ; do
@@ -200,8 +135,5 @@ src_install() {
for x in config.guess config.sub ; do
rm -f ${x} ; ln -sfn ../${x} ${x}
done
- cd ${S}
fi
-
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
}