summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-09 09:29:08 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-09 09:29:08 +0000
commit60a56b85a9a74bc79862b4fe0dcd530402399d00 (patch)
tree0cbf2fb9c71aadebed02b6da093a5cf9c04cd96f /sys-freebsd/freebsd-sources/files
parentFix header. (diff)
downloadhistorical-60a56b85a9a74bc79862b4fe0dcd530402399d00.tar.gz
historical-60a56b85a9a74bc79862b4fe0dcd530402399d00.tar.bz2
historical-60a56b85a9a74bc79862b4fe0dcd530402399d00.zip
Added a patch to stop DEBUG forcing -O if no COPTFLAGS defined to fix a kernel
panic on boot with sparc64. Package-Manager: portage-2.1.2.7
Diffstat (limited to 'sys-freebsd/freebsd-sources/files')
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch
new file mode 100644
index 000000000000..88a476b92233
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-6.2-debug-O2.patch
@@ -0,0 +1,28 @@
+My UltraSPARC U5 panics on boot about a memory alignment error when compiled
+with gcc4 and -O. Compiling with -O2 fixes this, and it should not adversly
+affect debugging.
+
+NOTE: This does not fix the memory alignment panic when loading kernel modules.
+
+Roy Marples (uberlord@gentoo.org)
+
+diff -ur a/conf/kern.pre.mk b/conf/kern.pre.mk
+--- a/conf/kern.pre.mk 2007-05-06 21:36:18 +0100
++++ b/conf/kern.pre.mk 2007-05-09 09:58:37 +0100
+@@ -19,15 +19,10 @@
+ .if ${CC} == "icc"
+ COPTFLAGS?= -O
+ .else
+-. if defined(DEBUG)
+-_MINUS_O= -O
+-. else
+-_MINUS_O= -O2
+-. endif
+ . if ${MACHINE_ARCH} == "amd64"
+ COPTFLAGS?=-O2 -frename-registers -pipe
+ . else
+-COPTFLAGS?=${_MINUS_O} -pipe
++COPTFLAGS?=-O2 -pipe
+ . endif
+ . if !empty(COPTFLAGS:M-O[23s]) && empty(COPTFLAGS:M-fno-strict-aliasing)
+ COPTFLAGS+= -fno-strict-aliasing